Bug 1317434 - [RFE] Implement live merge of auto-generated snapshot and backing file after live storage migration
[RFE] Implement live merge of auto-generated snapshot and backing file after ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
3.5.1
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Ala Hino
Kevin Alon Goldblatt
: FutureFeature
Depends On:
Blocks: 959705 1336214 1343922
  Show dependency treegraph
 
Reported: 2016-03-14 05:13 EDT by Yaniv Lavi (Dary)
Modified: 2017-01-24 07:41 EST (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, an auto-generated snapshot was created during live storage migration and had to be manually removed afterwards. With this release, the auto-generated snapshot is automatically deleted after live storage migration.
Story Points: ---
Clone Of: 959705
Environment:
Last Closed: 2016-07-05 04:00:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
gklein: testing_plan_complete-
ylavi: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 57302 master MERGED lsm: RFE: Remove auto-generated snapshot 2016-05-17 08:24 EDT

  None (edit)
Description Yaniv Lavi (Dary) 2016-03-14 05:13:01 EDT
Description of problem:
After live storage migration(LSM),the snapshot auto-generated during live storage migration has to be manually deleted after shutting down the VM.It would be nice if the auto-generated snapshot and its backing file could be live merged without having to shutdown the VM.

How reproducible:
Always

Steps to Reproduce:
1.Live migrate a disk attached to a VM from one SD to another
2.
3.
  
Actual results:
After LSM,the snapshot auto-generated during live storage migration has to be manually deleted after shutting down the VM.


Expected results:
VDSM should live merge the auto-generated snapshot and its backing file after LSM.
Comment 1 Sandro Bonazzola 2016-05-02 06:06:25 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Allon Mureinik 2016-06-05 09:25:06 EDT
Ala, this is a highly visible customer facing issue - please provide some doctext for it.
Comment 3 Kevin Alon Goldblatt 2016-06-07 07:20:54 EDT
Test the with the following code:
------------------------------------------
rhevm-4.0.0.2-0.1.el7ev.noarch
vdsm-4.18.1-11.gita92976e.el7ev.x86_64


Tested with the following scenario:
------------------------------------
1.Created 3 Storage Domains, iscsi, nfs and fc
2.Created a VM with disks on each of the SD
3.Started the Vm and then performed a LSM of each disk to a different SD >>>>>
The auto created snapshot is created successfully
On completion of the LSM the auto created sns is deleted
The size of the disks are updated correctly
Comment 4 Aharon Canan 2016-06-08 05:51:48 EDT
verified based on verification from https://bugzilla.redhat.com/show_bug.cgi?id=959705
Comment 5 Allon Mureinik 2016-06-23 11:46:23 EDT
Tahila - please also note documentation bug 1343903 which lists several places the removed behavior is listed. I'm guessing that and the doctext of this bug should somehow be handled together.
Comment 6 Tahlia Richardson 2016-06-24 01:13:18 EDT
Thanks Allon. We've got bug 1343903 in our first priority list of bugs for 4.0.
Comment 7 Sandro Bonazzola 2016-07-05 04:00:09 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.