This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1317436 - [RFE] Per cluster MAC address pool
[RFE] Per cluster MAC address pool
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Martin Mucha
Meni Yakove
http://www.ovirt.org/Features/Scoped_...
: FutureFeature
Depends On:
Blocks: 1298235 994283 1420586
  Show dependency treegraph
 
Reported: 2016-03-14 05:19 EDT by Yaniv Lavi (Dary)
Modified: 2017-02-15 10:05 EST (History)
23 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
MAC address pools are now bound to the cluster instead of the data center because certain environments require MAC address pools on the cluster level. On the REST layer, the mac_pool attribute was added to the cluster, and can be set or queried. The StoragePool resource (represents the Data Center) was also altered. When updating its mac_pool_id, all clusters in given Data Center will be updated to use this MAC address pool. When StoragePool is queried using the REST GET method, the ID of the MAC address pool will be reported only when all clusters in the given Data Center are using the same MAC address pool. Otherwise user needs to use the Cluster resource to get the MAC address pool of each individual cluster.
Story Points: ---
Clone Of: 994283
Environment:
Last Closed: 2017-02-15 10:05:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.1+
ylavi: exception+
mburman: testing_plan_complete+
ylavi: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 50755 master MERGED core: MacPool per Cluster; update db so that cluster references pool 2016-05-30 05:41 EDT
oVirt gerrit 50756 master MERGED core: MacPoolPerDc—>MacPoolPerCluster 2016-05-31 01:24 EDT
oVirt gerrit 51425 master MERGED restapi: moved reference to mac pool from DataCenter to Cluster 2016-06-01 08:24 EDT
oVirt gerrit 51426 master MERGED webadmin: moved reference to mac pool from DataCenter to Cluster 2016-06-01 06:33 EDT
oVirt gerrit 51427 master MERGED core: remove link to mac pool from storage pool. 2016-06-01 07:10 EDT
oVirt gerrit 51844 None None None 2016-03-14 05:19 EDT

  None (edit)
Description Yaniv Lavi (Dary) 2016-03-14 05:19:22 EDT
For certain environments, there are reasons to have a specific pool of MAC addresses for some systems and a different pool of MACs for other systems on a per cluster basis. Mac address pool per cluster is sometimes needed for security and deployment purposes.
Comment 1 Mike McCune 2016-03-28 19:09:17 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 2 Sandro Bonazzola 2016-05-02 06:09:52 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Sandro Bonazzola 2016-12-12 09:02:40 EST
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.
Comment 4 Michael Burman 2016-12-13 08:11:13 EST
Verified on - 4.1.0-0.2.master.20161210231201.git26a385e.el7.centos

Note You need to log in before you can comment on or make changes to this bug.