Bug 131744 - SMTP protocol violation, does not wait for SMTP server to respond, hence behaves like a spammer
Summary: SMTP protocol violation, does not wait for SMTP server to respond, hence beha...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Target FC6Desktop
TreeView+ depends on / blocked
 
Reported: 2004-09-03 20:28 UTC by Xander D Harkness
Modified: 2016-06-07 22:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-11 19:38:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 257951 None None None Never

Description Xander D Harkness 2004-09-03 20:28:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
When trying to send an email with evolution to an SMTP server that
enforces RFCs mail is rejected.

Evolution does not wait for the SMTP conversation and tries to jump
the process, just chucking all data at the SMTP server without waiting
for the normal procedure described in the RFC resulting in the
following error from the SMTP server:

2004-09-03 21:09:42 SMTP protocol violation: synchronization error
(input sent without waiting for greeting): rejected connection from
H=[IPADDRESS]

Version-Release number of selected component (if applicable):
evolution-1.5.94.1-1

How reproducible:
Always

Steps to Reproduce:
1.configure evolution to use an SMTP server that enforces the correct
SMTP handshake
2.click send and receive to get the error from Evolution: Welcome
response error: Connection reset by peer.
3.
    

Actual Results:  The mail is rejected with errors on both sides

Expected Results:  Evolution should negotiate the wait for the SMTP
greeting

Additional info:

The SMTP server used was exim 4.42

Comment 2 Xander D Harkness 2004-09-23 11:41:04 UTC
Sure,
relay.harkness.co.uk, which has IP addresses 80.234.135.40 and
3ffe:4005:100b:1:2d0:b7ff:fe00:cf14.

I will happily provide logs of access attempts too.

That 

Comment 4 Matthias Clasen 2006-07-06 22:03:57 UTC
Add to FC6Destop tracker

Comment 5 Ray Strode [halfline] 2006-07-25 21:47:25 UTC
Xander are you still seeing this?

Comment 6 Matthew Barnes 2006-08-01 17:02:29 UTC
For what it's worth, I run Exim 4.5 at home and can send mails from Evolution
2.7 to the server just fine.  Perhaps this has been fixed since Evolution 1.5.

I'll see if I can research this upstream.  Xander, do recall any upstream bugs
related to this?

Comment 7 Matthew Barnes 2006-08-01 17:16:21 UTC
I was only able to find one bug related to this upstream, but it turned out to
be a false alarm.  The fault was placed on TLS, not Evolution.

http://bugzilla.gnome.org/show_bug.cgi?id=257951

Comment 8 Matthew Barnes 2006-08-11 19:38:47 UTC
I can not confirm this behavior in current Rawhide packages, nor can I confirm
that this was ever actually a bug in Evolution.  Since this bug report is
approaching its 2nd birthday, I'm going to close this as NOTABUG and wait for
someone to report the problem again.

evolution-2.7.91-2


Note You need to log in before you can comment on or make changes to this bug.