Bug 131750 - CAN-2004-0832 Certain malformed NTLMSSP packets could crash the NTLM helpers provided by Squid
CAN-2004-0832 Certain malformed NTLMSSP packets could crash the NTLM helpers ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: squid (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 17:24 EDT by Josh Bressers
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 10:25:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2004-09-03 17:24:02 EDT
Description of problem:
Certain malformed NTLMSSP packets could crash the NTLM helpers 
provided by Squid.

Version-Release number of selected component (if applicable):
squid-2.5.STABLE5-5

Actual results / Expected results:
Patch applying, I'll attached a patch merged from upstream.

Additional info:
This bug report is *not* a duplicate of bug #125507, #125595 - it's 
a new issue.

Fedora Core is handled by bug 131728

attachment 103443 [details] contains a patch for this issue.


RHEL2.1 is not vulnerable to this issue.
Comment 1 Josh Bressers 2004-09-30 10:25:33 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2004-462.html

Note You need to log in before you can comment on or make changes to this bug.