Bug 1317505 - syncing a repo throws 500 ISE
Summary: syncing a repo throws 500 ISE
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Og Maciel
URL: https://pulp.plan.io/issues/1776
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-14 12:26 UTC by Kedar Bidarkar
Modified: 2019-09-26 15:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:27:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Pulp Redmine 1776 Normal CLOSED - CURRENTRELEASE sync_complete response has changed 2016-04-05 20:33:44 UTC

Description Kedar Bidarkar 2016-03-14 12:26:11 UTC
Created attachment 1136137 [details]
foreman-debug for sync issue

Description of problem:

Syncing a repo throws 500 ISE, but the sync does finish.

2016-03-14 08:00:21 [app] [I] Processing by Katello::Api::V2::RepositoriesController#sync_complete as */*
2016-03-14 08:00:21 [app] [I]   Parameters: {"_json"=>"{\"call_report\": {\"exception\": null, \"task_type\": \"pulp.server.managers.repo.sync.sync\", \"_href\": \"/pulp/api/v2/tasks/1c5269b6-6eed-4c45-928a-e8bc34f552f9/\", \"task_id\": \"1c5269b6-6eed-4c45-928a-e8bc34f552f9\", \"tags\": [\"pulp:repository:Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Hat_Satellite_Tools_6_1_for_RHEL_6_Server_RPMs_x86_64\", \"pulp:action:sync\"], \"finish_time\": null, \"_ns\": \"task_status\", \"start_time\": \"2016-03-14T11:59:55Z\", \"traceback\": null, \"spawned_tasks\": [], \"progress_report\": {\"yum_importer\": {\"content\": {\"items_total\": 84, \"state\": \"FINISHED\", \"error_details\": [], \"details\": {\"rpm_total\": 84, \"rpm_done\": 84, \"drpm_total\": 0, \"drpm_done\": 0}, \"size_total\": 12918556, \"size_left\": 0, \"items_left\": 0}, \"comps\": {\"state\": \"FINISHED\"}, \"purge_duplicates\": {\"state\": \"FINISHED\"}, \"distribution\": {\"items_total\": 0, \"state\": \"FINISHED\", \"error_details\": [], \"items_left\": 0}, \"errata\": {\"state\": \"FINISHED\"}, \"metadata\": {\"state\": \"FINISHED\"}}}, \"state\": \"running\", \"worker_name\": \"reserved_resource_worker-3@katello1.katello-latest.satellite.lab.eng.rdu2.redhat.com\", \"result\": null, \"error\": null, \"_id\": {\"$oid\": \"56e6a7ba322f0b20136c551e\"}, \"id\": \"56e6a7ba322f0b20136c551e\"}, \"event_type\": \"repo.sync.finish\", \"payload\": {\"importer_id\": \"yum_importer\", \"exception\": null, \"repo_id\": \"Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Hat_Satellite_Tools_6_1_for_RHEL_6_Server_RPMs_x86_64\", \"traceback\": null, \"started\": \"2016-03-14T11:59:55Z\", \"_ns\": \"repo_sync_results\", \"completed\": \"2016-03-14T12:00:21Z\", \"importer_type_id\": \"yum_importer\", \"error_message\": null, \"summary\": {\"content\": {\"state\": \"FINISHED\"}, \"comps\": {\"state\": \"FINISHED\"}, \"purge_duplicates\": {\"state\": \"FINISHED\"}, \"distribution\": {\"state\": \"FINISHED\"}, \"errata\": {\"state\": \"FINISHED\"}, \"metadata\": {\"state\": \"FINISHED\"}}, \"added_count\": 92, \"result\": \"success\", \"updated_count\": 0, \"details\": {\"content\": {\"size_total\": 12918556, \"items_left\": 0, \"items_total\": 84, \"state\": \"FINISHED\", \"size_left\": 0, \"details\": {\"rpm_total\": 84, \"rpm_done\": 84, \"drpm_total\": 0, \"drpm_done\": 0}, \"error_details\": []}, \"comps\": {\"state\": \"FINISHED\"}, \"purge_duplicates\": {\"state\": \"FINISHED\"}, \"distribution\": {\"items_total\": 0, \"state\": \"FINISHED\", \"error_details\": [], \"items_left\": 0}, \"errata\": {\"state\": \"FINISHED\"}, \"metadata\": {\"state\": \"FINISHED\"}}, \"id\": \"56e6a7d5952da6b12a30e99a\", \"removed_count\": 0}}", "token"=>"Vdh9zWpETDGdTvhDbjstM5FhAYrQ8G3o", "api_version"=>"v2", "repository"=>{}}
2016-03-14 08:00:21 [app] [E] NoMethodError: undefined method `[]' for nil:NilClass
 | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.6/app/controllers/katello/api/v2/repositories_controller.rb:234:in `sync_complete'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/abstract_controller/base.rb:189:in `process_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/action_controller/metal/rendering.rb:10:in `process_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:113:in `call'
 | /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/callbacks.rb:113:in `call'



Version-Release number of selected component (if applicable):
SNAP3-compose1

How reproducible:


Steps to Reproduce:
1. impport a manifest, enable repos
2. sync a repo
3.

Actual results:
sync finishes but throws 500 ISE 

Expected results:
sync should finish without any 500 ISE issues.

Additional info:

Comment 2 John Mitsch 2016-03-15 17:35:23 UTC
Created redmine issue http://projects.theforeman.org/issues/14214 from this bug

Comment 3 John Mitsch 2016-03-15 21:13:20 UTC
Turns out this is actually a pulp bug, upstream url updated

Comment 4 John Mitsch 2016-03-15 21:49:53 UTC
PR open https://github.com/pulp/pulp/pull/2490 that is set to 2.8.1 pulp release

Comment 5 pulp-infra@redhat.com 2016-03-18 15:03:52 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 6 pulp-infra@redhat.com 2016-03-18 15:03:55 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 7 pulp-infra@redhat.com 2016-03-23 19:00:25 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 8 pulp-infra@redhat.com 2016-03-29 13:03:37 UTC
The Pulp upstream bug status is at VERIFIED. Updating the external tracker on this bug.

Comment 9 Og Maciel 2016-04-04 19:10:48 UTC
I have sychronized dozens of repos and except for RHEL 5 repos, I have not been able to reproduce this issue. I'm closing it as VERIFIED on Satellite 6.2.0 SNAP 6.1

Comment 10 pulp-infra@redhat.com 2016-04-05 20:33:45 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 12 errata-xmlrpc 2016-07-27 09:27:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.