Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1317537 - 5.4.5.0 updated to 5.4.5.1 does not work properly (DOA?)
5.4.5.0 updated to 5.4.5.1 does not work properly (DOA?)
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity urgent
: GA
: 5.5.3
Assigned To: Gregg Tanzillo
Milan Falešník
: ZStream
Depends On:
Blocks: 1317906
  Show dependency treegraph
 
Reported: 2016-03-14 09:47 EDT by Milan Falešník
Modified: 2016-08-10 09:30 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1317906 (view as bug list)
Environment:
Last Closed: 2016-04-13 14:46:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mfalesni: automate_bug+


Attachments (Terms of Use)
Excerpt from production.log (76.83 KB, text/plain)
2016-03-14 09:47 EDT, Milan Falešník
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0616 normal SHIPPED_LIVE CFME 5.5.3 bug fixes and enhancement update 2016-04-13 18:38:44 EDT

  None (edit)
Description Milan Falešník 2016-03-14 09:47:52 EDT
Created attachment 1136158 [details]
Excerpt from production.log

Description of problem:
When an updated 5.4.5.1 CFME image is created from 5.4.5.0, it raises errors when booted up and configured.

Version-Release number of selected component (if applicable):
5.4.5.1 updated from 5.4.5.0 which was not set up before (a fresh appliance before database is set)

How reproducible:
always so far


Steps to Reproduce:
1. Prepare an updated image of 5.4.5.1 from 5.4.5.0 (spin up, add repos, yum update, seal the VM and templatize)
2. Boot it up, configure and wait for UI and try doing something

Actual results:
Error on the page and in logs, check the attachment.

Expected results:
CFME works as usual

Additional info:
This process worked before as the 5.4.5.0 in this case is already created the same or very similar way.
Comment 7 CFME Bot 2016-03-15 10:12:49 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a96a50accd91e3661cc4d58600055d02a40bbcaa

commit a96a50accd91e3661cc4d58600055d02a40bbcaa
Merge: f8c82a5 76e43b0
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Tue Mar 15 10:07:30 2016 -0400
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Tue Mar 15 10:07:30 2016 -0400

    Merge branch 'bz-1317537-secure-headers-config-fix-1' into '5.4.z'
    
    Fixing syntax error to address "SecureHeaders::STSBuildError"
    
    - Fixes fatal error: 'Error caught: [SecureHeaders::STSBuildError] The config value supplied for the HSTS header was invalid.'
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317537
    
    This was only broken downstream
    
    See merge request !849

 vmdb/config/initializers/secure_headers.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 CFME Bot 2016-03-15 10:12:53 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=76e43b0ce3daeb04ed5c8a2ef3a147a21023cc51

commit 76e43b0ce3daeb04ed5c8a2ef3a147a21023cc51
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Mon Mar 14 16:16:21 2016 -0400
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Mon Mar 14 16:16:21 2016 -0400

    Fixing syntax error to address "SecureHeaders::STSBuildError"
    - Fixes fatal error: 'Error caught: [SecureHeaders::STSBuildError] The config value supplied for the HSTS header was invalid.'
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317537

 vmdb/config/initializers/secure_headers.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 9 CFME Bot 2016-03-15 10:12:57 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7dac7ad02240d6d6ec8532fad1c440c4fe94436c

commit 7dac7ad02240d6d6ec8532fad1c440c4fe94436c
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Mon Mar 14 17:18:51 2016 -0400
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Mon Mar 14 17:18:51 2016 -0400

    Fixing syntax error to address "SecureHeaders::STSBuildError"
    - Fixes fatal error: 'Error caught: [SecureHeaders::STSBuildError] The config value supplied for the HSTS header was invalid.'
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317537

 config/initializers/secure_headers.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 10 CFME Bot 2016-03-15 10:13:01 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b6667562c4f7bfcf2cb08f18663074e40f600643

commit b6667562c4f7bfcf2cb08f18663074e40f600643
Merge: 873a422 7dac7ad
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Tue Mar 15 10:07:49 2016 -0400
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Tue Mar 15 10:07:49 2016 -0400

    Merge branch 'bz-1317537-secure-headers-config-fix-5-5-z' into '5.5.z'
    
    Fixing syntax error to address "SecureHeaders::STSBuildError"
    
    - Fixes fatal error: 'Error caught: [SecureHeaders::STSBuildError] The config value supplied for the HSTS header was invalid.'
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317537
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317537
    This was only broken downstream
    
    See merge request !850

 config/initializers/secure_headers.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 11 CFME Bot 2016-03-15 10:13:05 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b6667562c4f7bfcf2cb08f18663074e40f600643

commit b6667562c4f7bfcf2cb08f18663074e40f600643
Merge: 873a422 7dac7ad
Author:     Joe Rafaniello <jrafanie@redhat.com>
AuthorDate: Tue Mar 15 10:07:49 2016 -0400
Commit:     Joe Rafaniello <jrafanie@redhat.com>
CommitDate: Tue Mar 15 10:07:49 2016 -0400

    Merge branch 'bz-1317537-secure-headers-config-fix-5-5-z' into '5.5.z'
    
    Fixing syntax error to address "SecureHeaders::STSBuildError"
    
    - Fixes fatal error: 'Error caught: [SecureHeaders::STSBuildError] The config value supplied for the HSTS header was invalid.'
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317537
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1317537
    This was only broken downstream
    
    See merge request !850

 config/initializers/secure_headers.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 13 Milan Falešník 2016-03-24 09:18:31 EDT
Given the fact that 5.5.3.2 passed smoke tests and runs as usual, this can be moved to verified.
Comment 15 errata-xmlrpc 2016-04-13 14:46:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.