Bug 131757 - psacct does not work with large UIDs (> 65534)
psacct does not work with large UIDs (> 65534)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: psacct (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
NdRvw
:
: 62481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 19:07 EDT by Eric
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0409
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:41:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric 2004-09-03 19:07:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040803 Firefox/0.8

Description of problem:
I've stolen these descriptive words from Mr. Garrick:

The 2.4.x series of Linux kernels started using a 32 bit uid and gid
which raised the maximum number of users from 65536(2^16) to
4294967296(2^32). Unfortunately, the BSD process accounting system in
Linux was not likewise upgraded so that the binary accounting files
would remain compatible.  This might be fine for users that don't have
more than 65 thousand users, but it isn't suitable for those of us
with a large user base.

See more, including a proposed fix at:
http://www-rcf.usc.edu/~garrick/32bit-pacct-howto.txt

At our site we notice that process accounting is useless since all
large UIDs are shown in process accounting as belonging to UID 65534.
UIDs below that work fine. The rest of RHEL3 works fine with large
UIDs. Why not this part?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a large UID
2. Do something with it.
3. Check process accounting.
    

Additional info:
Comment 1 Charlie Bennett 2004-09-07 11:48:05 EDT
The 2.6 kernel has an option to configure 32-bit UID/GID in the
accounting subsystem (BSD_PROCESS_ACCT_V3).  There had been no plans
to backport this feature into the 2.4 kernels.

I'll take Mr. Garrick's patch to the kernel team and see if we can get
it into the next update.  If you escalate this issue through support
(https://www.redhat.com/apps/support) it'll be an easier sell from my
side.
Comment 2 Charlie Bennett 2004-09-07 11:49:13 EDT
*** Bug 62481 has been marked as a duplicate of this bug. ***
Comment 3 Ivana Varekova 2005-05-13 06:26:26 EDT
Hello,
psacct uses command acct and data type acct to get information about executed
commands. They use only 16b to store uid.
To fix this problem at first this command and data structure must be changed.
Ivana Varekova
Comment 4 Ernie Petrides 2005-05-13 15:57:18 EDT
Hello, Ivana.  The RHEL3 kernel already has the 32-bit extensions to
the "acct" structure and seems to assign both pairs of ac_uid/ac_gid
and ac_uid32/ac_gid32 properly.  Why did you reassign this to the
"kernel" component?
Comment 5 Andy Grimm 2005-05-17 20:46:57 EDT
I guess I should chime in on this again... this bug was fixed a long time ago
with a RH kernel patch; my understanding was that Red Hat just decided not to
compile psacct with the 32-bit UID option by default, but with the right option
to the "configure" command in the SPEC file, I think the src rpm will rebuild
and work just fine.  I have not tried in a while, but it actually worked back on
RH7.3...
Comment 6 Ernie Petrides 2005-05-19 18:33:25 EDT
Thanks for the background, Andy.  Reassigning to the "psacct" component.
Comment 13 Red Hat Bugzilla 2007-06-11 14:41:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0409.html

Note You need to log in before you can comment on or make changes to this bug.