Bug 1317679 - activation key product content is not shown when multiple orgs share content
Summary: activation key product content is not shown when multiple orgs share content
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
Depends On: 1250610
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-14 20:39 UTC by Tom McKay
Modified: 2019-09-26 18:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:27:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description Tom McKay 2016-03-14 20:39:18 UTC
To reproduce:
1. import manifest w/ product RHEL into org A
2. import manifest w/ product RHEL into org B
3. in org A, enable a repo such as sat tools 7Server
4. create act key
5. add RHEL subscription to act key
6. note product content page of act key
7. in org B, enable repo sat tools 7Server
8. create act key
9. add RHEL subscription to act key
10. note product content page of act key

What I am seeing is that the act key in org B is not showing any product content repos to enable. I think the above will reproduce issue.

Comment 1 Tom McKay 2016-03-14 20:39:20 UTC
Created from redmine issue http://projects.theforeman.org/issues/14194

Comment 3 Christine Fouant 2016-03-29 20:11:54 UTC
Fixed by https://github.com/Katello/katello/pull/5919

Comment 4 Tom McKay 2016-03-29 23:14:18 UTC
This is a different bug than 1250610. The UI and hammer, incorrectly in my opinion, use different APIs to get product content for activation keys. The UI is still broken and is not fixed by https://github.com/Katello/katello/pull/5919

Comment 5 Tom McKay 2016-03-30 01:18:02 UTC
Confirmed fixed.

Comment 6 sthirugn@redhat.com 2016-04-04 20:33:12 UTC
Failed in Satellite 6.2-beta-snap-6.1

activation key -> product content still fails when I have multilple orgs with RH repos enabled.

Comment 7 sthirugn@redhat.com 2016-04-07 13:35:12 UTC
Verified in satellite-6.2.0-6.2.beta.el7sat.noarch

Verification steps:
1. import manifest w/ product RHEL into org A
2. import manifest w/ product RHEL into org B
3. in org A, enable/sync rhel repos, also create custom products
4. create act key
5. add RHEL subscription/custom subscription to act key
6. note product content page of act key
7. Repeat steps 3 through 6 for Org B
8. create act key in Org B
9. note product content page of act key in Org B
10. The product content page of both Org A and Org B show their specific product contents only.

Comment 9 errata-xmlrpc 2016-07-27 09:27:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.