Bug 1317702 - Fedora Scientific needs julia-0.4.3-7
Summary: Fedora Scientific needs julia-0.4.3-7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: julia
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Bouchet-Valat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F24AlphaFreezeException F24FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-03-14 23:03 UTC by Amit Saha
Modified: 2016-03-18 15:19 UTC (History)
4 users (show)

Fixed In Version: julia-0.4.3-7.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-18 15:19:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Amit Saha 2016-03-14 23:03:42 UTC
Description of problem:


The Fedora Scientific spin is failing to build with:

nothing provides libopenlibm.so.1 needed by julia-0.4.3-6.fc24.i686.

A fix is available as julia-0.4.7 (https://bodhi.fedoraproject.org/updates/FEDORA-2016-9b00c41a10)

We just need for it to be pushed to updates.

Version-Release number of selected component (if applicable):

0.4.3-6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Fedora Blocker Bugs Application 2016-03-14 23:05:22 UTC
Proposed as a Freeze Exception for 24-final by Fedora user amitksaha using the blocker tracking app because:

 Fedora Scientific spin build is failing, and addition of Julia is a highlight of the Fedora 24 Scientific Spin release.

Comment 2 Adam Williamson 2016-03-15 00:05:41 UTC
+1 FE, would fix compose of a spin we ship and doesn't look like it'd break anything else.

Comment 3 Fedora Blocker Bugs Application 2016-03-15 00:19:03 UTC
Proposed as a Freeze Exception for 24-alpha by Fedora user amitksaha using the blocker tracking app because:

 Fedora Scientific spin build is failing, and addition of Julia is a highlight of the Fedora 24 Scientific Spin release.

Comment 4 Stephen Gallagher 2016-03-15 00:19:31 UTC
+1 FE, nice and self-contained.

Comment 5 Dennis Gilmore 2016-03-15 16:31:56 UTC
+1 FE

Comment 6 Milan Bouchet-Valat 2016-03-15 16:43:15 UTC
FWIW, the release of 0.4.4 is imminent, so you may want to wait for a few days more (I'll package it immediately).

Comment 7 Adam Williamson 2016-03-15 18:05:39 UTC
No, we don't want new releases. We only want to solve dependency issues. We are frozen.

Comment 8 Fedora Update System 2016-03-16 08:01:58 UTC
julia-0.4.3-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9b00c41a10

Comment 9 Adam Williamson 2016-03-16 18:54:14 UTC
Marking as accepted FE.

Comment 11 Fedora Update System 2016-03-18 15:19:31 UTC
julia-0.4.3-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.