Bug 1317721 - cockpit.socket not enabled automatically on Fedora Server installs
Summary: cockpit.socket not enabled automatically on Fedora Server installs
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-release
Version: 24
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: F24AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-15 00:39 UTC by Stephen Gallagher
Modified: 2016-03-23 16:20 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-23 16:20:59 UTC


Attachments (Terms of Use)

Description Stephen Gallagher 2016-03-15 00:39:19 UTC
Description of problem:
I installed Fedora Server from the Fedora-24-20160314.n.0/ compose. It installed successfully, but after boot I was unable to access the Cockpit admin console. Looking at `systemctl status cockpit.socket`, I noticed that it was listed as "disabled". Investigating /usr/lib/systemd/system-preset/, I discovered that the expected symlink to 80-server.preset is missing.

Version-Release number of selected component (if applicable):
fedora-release-server-24-0.14.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Install a recent Fedora Server from any install media
2. Attempt to access the Cockpit admin console on port 9090 with a supported web browser
3.

Actual results:
Connection is refused

Expected results:
The Cockpit admin console should be presented

Additional info:
Looks like fallout from the conversion of the setup scripts to lua. Running the bash `convert-to-edition` script properly creates the symlink.

Comment 1 Fedora Blocker Bugs Application 2016-03-15 00:41:21 UTC
Proposed as a Blocker for 24-alpha by Fedora user sgallagh using the blocker tracking app because:

 "after system installation the Cockpit web management interface must be running and accessible on its default port (9090)."

Comment 2 Stephen Gallagher 2016-03-15 02:32:17 UTC
Pull-requests out for review:

https://pagure.io/fedora-release/pull-request/40 (F24)
https://pagure.io/fedora-release/pull-request/39 (Rawhide/F25)

Comment 3 Kamil Páral 2016-03-15 12:27:22 UTC
+1 alpha blocker

Comment 4 Petr Schindler 2016-03-15 12:30:13 UTC
+1 alpha blocker

Comment 5 Jan Sedlák 2016-03-15 12:31:32 UTC
+1 alpha blocker

Comment 6 Kamil Páral 2016-03-15 12:32:16 UTC
Accepted as an Alpha blocker per votes above.

Comment 7 Fedora Update System 2016-03-15 17:09:19 UTC
fedora-release-24-0.15 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1723cd4bfb

Comment 8 Fedora Update System 2016-03-15 21:29:58 UTC
fedora-release-24-0.15 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1723cd4bfb

Comment 9 Adam Williamson 2016-03-17 07:19:55 UTC
Testing with Alpha candidate 5, cockpit.socket shows as 'enabled', but I still cannot access Cockpit out of the box after a default Server DVD install. I have to manually 'systemctl start cockpit.service' before it will work. I tested both from a remote system and from localhost using links.

Comment 10 Petr Schindler 2016-03-17 09:21:11 UTC
Same here with Alpha c. 5. I have to start cockpit.service (which is disabled by default) to be able to connect.

Comment 11 Stephen Gallagher 2016-03-17 14:24:04 UTC
OK, the first patches properly put the presets in place, but the actual enabling of them silently failed. New patches enable as well.

https://pagure.io/fedora-release/pull-request/42 (Fedora 24)
https://pagure.io/fedora-release/pull-request/41 (Fedora 25/Rawhide)

Comment 12 Fedora Update System 2016-03-18 19:37:51 UTC
fedora-release-24-0.16 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e62d4924ed

Comment 13 Chris Murphy 2016-03-20 01:53:09 UTC
Fedora-Server-netinst-x86_64-24_Alpha-1.6.iso still does not have cockpit starting by default; I can login and systemctl start cockpit and now it's active/running. If I reboot the server, it's no longer active.

Comment 14 Fedora Update System 2016-03-20 03:58:23 UTC
fedora-release-24-0.16 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e62d4924ed

Comment 15 Adam Williamson 2016-03-21 02:15:48 UTC
Confirmed fixed in Alpha-1.6, thanks. Cockpit is accessible on boot.

Comment 16 Adam Williamson 2016-03-21 02:16:41 UTC
Chris: the service won't show as running if you check it, because it's socket activated. You just have to try and connect to it and see if that works. It does for me. If you're using the netinst, though, you may not be getting the updated fedora-release anyway, it is best to test with the DVD.

Comment 17 Chris Murphy 2016-03-21 03:28:06 UTC
Yep nevermind, it does work on a new installation upon connecting.

Comment 18 Kamil Páral 2016-03-21 15:10:21 UTC
Tested with Alpha 1.6 Server DVD, works fine.

Comment 19 Fedora Update System 2016-03-23 16:20:54 UTC
fedora-release-24-0.16 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.