Bug 1317739 - [RFE] HE deploy setup should use the configured nic as a default option for ovirtmgmt bridge
Summary: [RFE] HE deploy setup should use the configured nic as a default option for o...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup   
(Show other bugs)
Version: 3.6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.2
: 4.2.0
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Keywords: FutureFeature, TestOnly, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 03:17 UTC by Marina
Modified: 2018-05-15 17:34 UTC (History)
17 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.16
Doc Type: Enhancement
Doc Text:
In the current release, during the hosted engine deployment, if only one configured NIC is available on the host, it is offered as the default option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-05-15 17:32:21 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nsednev: testing_plan_complete-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1471 None None None 2018-05-15 17:34 UTC

Description Marina 2016-03-15 03:17:05 UTC
Description of problem:
HE deploy setup should use the configured nic as a default option for ovirtmgmt bridge. Right now it shows first on the list. However, since all the other default options in the setup are reasonable, the user tends to choose the suggested default option here as well and the setup fails. 
Since there is only 1 configured nic available on the host at a time of HE deployment, the setup should suggest it as the default option.

Example:
~~~
 Please indicate a nic to set ovirtmgmt bridge on: (enp0s26u1u2u5, eno1, eno2) [enp0s26u1u2u5]: eno1
~~~

Version-Release number of selected component (if applicable):
3.6 RHEV-H HE deployment

How reproducible: 100% on my machine.

It seems like it might be an easy fix that may prevent many failed setup and frustration and customer cases, of course.

Comment 1 Fabian Deutsch 2016-03-16 09:10:37 UTC
To me this looks like something which he-setup in general would benefit from.

Comment 2 Yaniv Lavi 2017-12-03 12:46:49 UTC
Does node zero deployment affect this?

Comment 3 Sandro Bonazzola 2018-02-20 09:52:42 UTC
Moving needinfo to Simone

Comment 4 Simone Tiraboschi 2018-02-20 09:55:07 UTC
On node-zero we are filtering on interfaces with an IPv4 address.

Comment 5 Yaniv Lavi 2018-02-26 12:44:23 UTC
(In reply to Simone Tiraboschi from comment #4)
> On node-zero we are filtering on interfaces with an IPv4 address.

So it's not solved?

Comment 6 Simone Tiraboschi 2018-02-26 12:52:48 UTC
If only one interface is configured with an IPv4 address we are fine, if we have more than one interface with IPv4 address we are presenting the list without any special ordering criteria.

Comment 7 Yaniv Lavi 2018-02-26 12:59:42 UTC
(In reply to Simone Tiraboschi from comment #6)
> If only one interface is configured with an IPv4 address we are fine, if we
> have more than one interface with IPv4 address we are presenting the list
> without any special ordering criteria.

QE please test this.

Comment 8 Nikolai Sednev 2018-04-09 14:15:10 UTC
Tested on latest components as follows:
cockpit-ovirt-dashboard-0.11.20-1.el7ev.noarch
rhvm-appliance-4.2-20180404.0.el7.noarch
ovirt-hosted-engine-setup-2.2.16-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.10-1.el7ev.noarch
Linux 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)

I see configured NIC as default option as expected.

Comment 11 errata-xmlrpc 2018-05-15 17:32:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1471


Note You need to log in before you can comment on or make changes to this bug.