Bug 1317740 - [Docs][SHE] 60GB of /tmp requirements for the appliance installation are incorrect
Summary: [Docs][SHE] 60GB of /tmp requirements for the appliance installation are inco...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.6.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-3.6.7
: ---
Assignee: Julie
QA Contact: Tahlia Richardson
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 03:45 UTC by Marina Kalinin
Modified: 2017-04-04 19:22 UTC (History)
21 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-30 01:58:27 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2991641 None None None 2017-04-04 19:22 UTC

Description Marina Kalinin 2016-03-15 03:45:02 UTC
[Self-Hosted_Engine_Guide]
SHE Installation Guide on RHEV-H advice that:
"To use the appliance, the /tmp directory must be at least 60 GB". 
This is incorrect.
/tmp is tmpfs on RHEL7, which means it would need at least 60GB of RAM available for this, if I understand that correctly. And this is not always possible. However, it is not needed, since I could install the HE using the appliance without having the 60GB in /tmp without a problem. That's why I suggest to remove this recommendation from the guide.

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Self-Hosted_Engine_Guide/Configuring_Self-Hosted_Engine_on_Red_Hat_Enterprise_Virtualization_Hypervisor.html


Version-Release number of selected component (if applicable):
3.6

Filesystem            Size
/dev/mapper/live-rw   1.5G
devtmpfs              16G
tmpfs                 16G
tmpfs                 16G
tmpfs                 16G
/dev/mapper/3600508e0000000008bf78c96c7887307p2              4.0G
none                  16G
/dev/mapper/HostVG-Logging             2.0G
/dev/mapper/HostVG-Config              6.8M
/dev/mapper/HostVG-Data                241G
tmpfs                 3.2G
netapp-fas2240-1-ctrl1.gsslab.rdu2.redhat.com:/vol/vol_RHEV_HOSTED_ENGINE_01              50G
/dev/loop4            2.0G
[

Comment 1 Yaniv Lavi 2016-03-16 12:42:24 UTC
Do you agree with the above statement?

Comment 2 Fabian Deutsch 2016-03-16 13:43:10 UTC
On RHEV-H /var/tmp is used - which resides on-disk.
If we can use /var/tmp by default in hosted-engine-setup, then we could have on documentation for both.

Comment 3 Marina Kalinin 2016-03-17 17:54:42 UTC
Fabian, 
I am not sure I understand you.
However, from 3.6 GA RHEV-H:
~~~
# mount | grep '/var/tmp'
none on /var/tmp type tmpfs (rw,relatime,seclabel)
~~~

Comment 4 Fabian Deutsch 2016-03-21 12:23:27 UTC
Hm, /var/tmp should not be a tmpfs.

Douglas, can you check why /var/tmp is a tmpfs.

Comment 5 Douglas Schilling Landgraf 2016-03-24 14:56:37 UTC
(In reply to Marina from comment #0)
> [Self-Hosted_Engine_Guide]
> SHE Installation Guide on RHEV-H advice that:
> "To use the appliance, the /tmp directory must be at least 60 GB". 
> This is incorrect.
> /tmp is tmpfs on RHEL7, which means it would need at least 60GB of RAM
> available for this, if I understand that correctly. And this is not always
> possible. However, it is not needed, since I could install the HE using the
> appliance without having the 60GB in /tmp without a problem. That's why I
> suggest to remove this recommendation from the guide.
> 
> https://access.redhat.com/documentation/en-US/
> Red_Hat_Enterprise_Virtualization/3.6/html/Self-Hosted_Engine_Guide/
> Configuring_Self-
> Hosted_Engine_on_Red_Hat_Enterprise_Virtualization_Hypervisor.html
> 
> 
> Version-Release number of selected component (if applicable):
> 3.6
> 
> Filesystem            Size
> /dev/mapper/live-rw   1.5G
> devtmpfs              16G
> tmpfs                 16G
> tmpfs                 16G
> tmpfs                 16G
> /dev/mapper/3600508e0000000008bf78c96c7887307p2              4.0G
> none                  16G
> /dev/mapper/HostVG-Logging             2.0G
> /dev/mapper/HostVG-Config              6.8M
> /dev/mapper/HostVG-Data                241G
> tmpfs                 3.2G
> netapp-fas2240-1-ctrl1.gsslab.rdu2.redhat.com:/vol/vol_RHEV_HOSTED_ENGINE_01
> 50G
> /dev/loop4            2.0G
> [

Hi Marina,

Thanks for the report.
The correct tmp dir that store the appliance is:

(from ovirt-node-plugin-hosted-engine source code)
$ cat configure.ac

<snip>
AC_SUBST([HE_TMP_DIR], ['/data/ovirt-hosted-engine-setup/tmp-setup'])
</snip>

In that case, it's the partition /data (ext4) that requires 60G at least.

Comment 6 Fabian Deutsch 2016-03-24 15:17:24 UTC
Thanks Douglas.

/data maps to the Data partition term as it is used in:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Installation_Guide/chap-Red_Hat_Enterprise_Virtualization_Hypervisor.html

Thus the sentence:

""" You must have prepared storage for your self-hosted engine environment. For more information on preparing storage for your deployment, see the Storage chapter in the Administration Guide. The storage share must be at least 60 GB. """

should become something like

""" You must have prepared storage for your self-hosted engine environment. The Data volume share must be at least 60 GB, see the Installing the Red Hat Enterprise Virtualization Hypervisor in the Installation Guide."""


In addition the sentence Marina initialy mentioned:

[Self-Hosted_Engine_Guide]
SHE Installation Guide on RHEV-H advice that:
"To use the appliance, the /tmp directory must be at least 60 GB". 

Should be rendered more precisely and include that on RHEV-H the Data volume should be at least 60GB in size.

Does this make sense Julie, Marina?

Comment 7 Marina Kalinin 2016-03-24 15:24:06 UTC
Yes.

Comment 9 Mike McCune 2016-03-28 23:25:37 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 11 Lucy Bopf 2016-04-01 01:12:21 UTC
Assigning Tahlia as QA contact.

Tahlia, can you please take a look at the changes that were included for this bug?

Comment 18 Marina Kalinin 2016-06-24 17:08:28 UTC
Hi Julie,
Not sure about the RHEL flow, the comment about /var/tmp was related to RHEV-H. It will check if there is enough space, it will use it, if not, it will use the /data. Maybe RHEL would do something similar.

Honestly, I didn't review in details RHEL setup docs.
However, for RHEVH, the problem is that there are 2 different locations in the doc that require /data(one place) and /var/tmp(another place) to be 60G. Which is incorrect.

Comment 19 Julie 2016-06-27 00:58:23 UTC
Hi Marina,
   Actually, in the current published docs, all the RHEL procedures have /tmp requires 60 GB (Chapter3 & 5), and RHEV-H procedures have data partition requires 60GB(Chapter2). 

After checking the RHEL setup again, I can confirm it checks /var/tmp and then asks users to specify a directory with enough space. /data is not created by default on a standard RHEL machine. 

To clarify, for all RHEV-H procedures, I've made clear that the data partition (/data) needs to be 60GB.

For all RHEL procedures:
... ensure one directory is at least 60 GB. The <command>hosted-engine</command> script first checks if <filename>/var/tmp</filename> has enough space to extract the appliance files. If not, you can specify a different directory.

Kind regards,
Julie


Note You need to log in before you can comment on or make changes to this bug.