This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 131783 - gpm does not compile
gpm does not compile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-04 10:36 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.20.1-50
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 14:33:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This patch adds the defines for configure to use. (598 bytes, patch)
2004-09-04 10:37 EDT, Steve Grubb
no flags Details | Diff
This patch fixes the spec file (788 bytes, patch)
2004-09-04 10:38 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2004-09-04 10:36:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
When gpm is compiled using the latest glibc-kernheaders, 2.4-9.1.87,
it does not compile. This is because the config.h.in file does not
have the defines for the structures.

Additionally, gpm is missing a couple buildrequires.

Version-Release number of selected component (if applicable):
gpm-1.20.1-49

How reproducible:
Always

Steps to Reproduce:
1. install or upgrade to glibc-kernheaders-2.4-9.1.87
2. rpmbuild -bb gpm.spec

Actual Results:  headers/input-defines.h:63: error: redefinition of
`struct input_id'
headers/input-defines.h:72: error: redefinition of `struct input_absinfo'
make[1]: *** [evdev.o] Error 1
make: *** [do-all] Error 1


Expected Results:  A message saying where the rpm was written.

Additional info:

I will attach 2 patches that fix these problems.
Comment 1 Steve Grubb 2004-09-04 10:37:40 EDT
Created attachment 103466 [details]
This patch adds the defines for configure to use.
Comment 2 Steve Grubb 2004-09-04 10:38:42 EDT
Created attachment 103467 [details]
This patch fixes the spec file

Please apply
Comment 3 Eido Inoue 2004-09-23 14:33:53 EDT
thanks for the patch. applied.

Note You need to log in before you can comment on or make changes to this bug.