Bug 1317861 - Probing a new node, which is part of another cluster, should throw proper error message in logs and CLI
Summary: Probing a new node, which is part of another cluster, should throw proper er...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Gaurav Kumar Garg
QA Contact:
URL:
Whiteboard: glusterd
Depends On: 1252448
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 11:49 UTC by Gaurav Kumar Garg
Modified: 2016-04-19 06:59 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Clone Of: 1252448
Environment:
Last Closed: 2016-04-19 06:59:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-03-15 11:51:41 UTC
REVIEW: http://review.gluster.org/13741 (glusterd: probing a new node, which is part of another cluster should give error) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Vijay Bellur 2016-03-22 07:06:18 UTC
COMMIT: http://review.gluster.org/13741 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 2512bb829a10d9d087a0c7d2a4217b90b60e3845
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Tue Aug 11 18:17:31 2015 +0530

    glusterd: probing a new node, which is part of another cluster should give error
    
    This patch is backport of: http://review.gluster.org/#/c/11884/
    
    If user try to add node to extant cluster using "gluster peer probe \
    <ip/hostname>" command then command is failing but its not giving
    proper cause of failure.
    
    This fix will take control of proper error message during peer probe
    with already extant cluster.
    
    Change-Id: I4f993e78c0e1b3e061153b984ec5e9b70085aef5
    BUG: 1317861
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    
      >> Change-Id: I4f993e78c0e1b3e061153b984ec5e9b70085aef5
      >> BUG: 1252448
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
      >> Reviewed-on: http://review.gluster.org/11884
      >> Tested-by: NetBSD Build System <jenkins@build.gluster.org>
      >> Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    (cherry picked from commit 31a36dca20a976b143cc5c970e115d8d36df847a)
    
    Change-Id: I0066d8b3b70346b123ab5f3b32a6cf8e54d242fc
    Reviewed-on: http://review.gluster.org/13741
    Tested-by: Gaurav Kumar Garg <ggarg@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Kaushal 2016-04-19 06:59:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.