Bug 131787 - User with same name as computer is not avaible thru NSS
User with same name as computer is not avaible thru NSS
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-04 11:00 EDT by Radek Hladik
Modified: 2014-08-31 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 13:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Hladik 2004-09-04 11:00:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7.2)
Gecko/20040803

Description of problem:
I've just upgraded to samba 3.0.6-fc2 (using up2date) and NSS stopped
serving information for my user. My username is Radek and my computer
hostname is radek.twobears.cz. I think that this is the problem as
other user worked OK. My username was still listed in 'getent passwd'
with all information and 'wbinfo -u ' worked as well. But getent
passwd Radek produced nothing and I was unable to log on.
Downgrading back to 3.0.3  solved the issue.


Version-Release number of selected component (if applicable):
3.0.6-fc2

How reproducible:
Didn't try

Steps to Reproduce:
1. upgrade samba to 3.0.6-fc2
2. have user named the same as computer (I think that this is the problem)
3. getent passwd user
    

Actual Results:  No passwd record.

Expected Results:  Correct passwd record as listed in getent passwd

Additional info:
Comment 1 Matthew Miller 2005-04-26 11:33:00 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 2 John Thacker 2006-10-28 13:17:31 EDT
Note that FC1 and FC2 are no longer supported even by Fedora Legacy.  Many
changes have occurred since these older releases.  Please install a supported
version of Fedora Core and retest.  If this still occurs on FC3 or FC4, please
assign to that version and Fedora Legacy.  If it still occurs on FC5 or FC6,
please reopen and assign to the correct version.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.