Bug 1317887 - Review Request: libfastjson - C json library
Summary: Review Request: libfastjson - C json library
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Sykora
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE-NEEDSPONSOR
TreeView+ depends on / blocked
 
Reported: 2016-03-15 12:55 UTC by Radovan Sroka
Modified: 2017-02-01 12:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 12:01:10 UTC
Type: ---
tosykora: fedora-review+


Attachments (Terms of Use)

Description Radovan Sroka 2016-03-15 12:55:59 UTC
Spec URL: http://www.stud.fit.vutbr.cz/~xsroka00/libfastjson.spec
SRPM URL: http://www.stud.fit.vutbr.cz/~xsroka00/libfastjson-0.99.2-1.fc23.src.rpm
Description: Json C library, dependency of Rsyslog v8.16+
Fedora Account System Username: rsroka

Comment 1 Rich Megginson 2016-04-01 23:19:17 UTC
Looks good.  rpmlint check passes.  Only a couple of minor issues:

"
BuildRequires:	autoconf
BuildRequires:	automake
BuildRequires:	libtool
BuildRequires:	glibc-common
"

Does the build actually require autoconf, automake, libtool?  I don't see any call to `autoreconf` or the like.  Does the build require gcc?  Other similar build tools?  Looks like glibc-common is for iconv.  I suggest using

"
BuildRequires:  glibc-common
BuildRequires:  gcc
"

Please make sure the Changelog section looks like this: https://fedoraproject.org/wiki/Packaging:Guidelines#Changelogs
That is, line begins with a dash "-" followed by a single space " " followed by the text.

Comment 2 Radovan Sroka 2016-04-04 10:42:55 UTC
Hi Rich,

You're right. It's updated.

Thanks for review.

Comment 3 Rich Megginson 2016-04-05 18:26:46 UTC
looks good

Comment 4 Peter Portante 2016-04-08 09:38:17 UTC
Is this .spec file derived from https://github.com/rsyslog/rsyslog-pkg-rhel-centos/blob/master/rpmbuild/SPECS/libfastjson.spec ?

Comment 5 Peter Portante 2016-04-08 11:38:06 UTC
I have tried it out locally on my F21 box, and it builds cleanly.  I have created a COPR build for all supported streams, and it seems to have succeed for epel7 and fedora builds, but failed for epel 5 and epel 6.

See https://copr.fedorainfracloud.org/coprs/portante/libfastjson/build/173999/

I'd like to see this spec file sync'd up with the existing one at:

https://github.com/rsyslog/rsyslog-pkg-rhel-centos/blob/master/rpmbuild/SPECS/libfastjson.spec

Comment 6 Radovan Sroka 2016-04-11 08:35:56 UTC
Hi Peter,

My spec was derived from json-c library.

Thanks for your review, there are new files:

http://www.stud.fit.vutbr.cz/~xsroka00/libfastjson.spec
http://www.stud.fit.vutbr.cz/~xsroka00/libfastjson-0.99.2-2.fc23.src.rpm


rsroka

Comment 7 Peter Portante 2016-04-14 21:20:49 UTC
Looks good to me.  I build it locally on F21, and took that source tar ball and ran it through a full COPR build and it all possible environments built.

See: https://copr.fedorainfracloud.org/coprs/portante/libfastjson/monitor/

Just curious, how come we don't use autoconf?

Thanks!

Comment 8 Tomas Heinrich 2016-04-15 08:10:04 UTC
(In reply to Peter Portante from comment #7)
> Just curious, how come we don't use autoconf?

There doesn't seem to be any need for it (correct me if I'm wrong).

The EPEL5 build would fail due to a missing macro but that is worked around by adding -D_GNU_SOURCE to CFLAGS. Upstream solved this by adding AC_PROG_CC_C99 to configure.ac in the upcoming release.

A spec file from upstream mentions running autoreconf to get rid of rpath. I haven't observed it being added in either Fedora or EPEL builds even without autoreconf.

Comment 9 Michael Schwendt 2016-05-26 20:33:59 UTC
> Name: libfastjson
> Group: Development/Libraries

And after many years, in 2016 the base group for runtime library packages still is "System Environment/Libraries". I wonder which packages you've looked at as examples?

Btw, nowadays the Group tag is optional:
https://fedoraproject.org/wiki/Packaging:Guidelines#Tags_and_Sections


> Requires:	pkgconfig

Unjustified and overly restrictive. There is absolutely no need for an explicit dependency on pkgconfig. Certainly you could use libfastjson-devel without using pkg-config. Further, for several years already, there are automatic Requires/Provides for packages containing and depending on .pc files.


> %check
> make V=1 check
>
> %install

That's the wrong order of those sections. Not a major issue, but the %check section is processed _after_ %install (so it would be possible to run checks inside the buildroot).

Comment 11 Tomas Sykora 2016-09-27 09:34:31 UTC
I made a review of the package, everything seems OK.

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig called in %post and %postun if required.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
[x]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Scriptlets must be sane, if used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Spec file according to URL is the same as in SRPM.
[x]: Rpmlint is run on debuginfo package(s).
     Note: No rpmlint messages.
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.

Comment 12 Gwyn Ciesla 2016-09-27 13:06:42 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/libfastjson


Note You need to log in before you can comment on or make changes to this bug.