Bug 13179 - RFE: add versioning to *.rpm{orig,new} dupes
RFE: add versioning to *.rpm{orig,new} dupes
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-28 11:34 EDT by R P Herrold
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-30 01:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2000-06-28 11:34:35 EDT
Request: Please add versioning to *.rpm{orig,new} dupes

Extracted from a thread from the testers-list 6/28/00:

> > Setup RPM seems to create a lot of unnecessary *.rpm{orig,new} files
> > in /etc.  Of these, _at least_ the following had nothing changed in 
> > them (diff'ed), but still the file had been created:

[R P Herrold]

> ... wow.  I'd call that a feature, not a bug.  I'd really prefer
> that the .rpm{orig,new} generation logic was even MORE verbose ---
> appending a .1, .2, etc. if it finds one already present.
 
That's a good suggestion.  Perhaps .rpm{orig,new} should ne appended with
a number if they exist before just as you propose.
 
BUT, it isn't a feature to create identical file (shows no differences
with diff) of a config file.  That's just one false alarm, and if
sysadmin would know that .rpm{orig,new} always means business, the result
is less likely to get messy.
Comment 1 Jeff Johnson 2000-07-31 11:37:15 EDT
I don't believe that adding versioning to saved files is the right approach, as
most users find even the existence of *.rpmorig and *.rpmnew confusing. Adding
versioning, while easy, is only going to make rpm even more confusing to users.

Note You need to log in before you can comment on or make changes to this bug.