Bug 1317968 - Publishing or Promoting a content view with a non-running capsule pauses the task with error
Summary: Publishing or Promoting a content view with a non-running capsule pauses the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Og Maciel
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 16:08 UTC by Justin Sherrill
Modified: 2019-09-26 15:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:27:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14207 None None None 2016-04-22 15:52:05 UTC

Description Justin Sherrill 2016-03-15 16:08:13 UTC
Description of problem:

Very similar to older problems we had, if you publish or promote a content view and there is a capsule attached to the lifecycle environment the publish/promote will get most of the way done and then pause with an error saying 'Connection refused'

Version-Release number of selected component (if applicable):
6.2 snap 3


How reproducible:
Always

Steps to Reproduce:
1.  Register a capsule and assign it to Library and Dev
2.  Shut down httpd on the capsule
3.  Publish a content view with at least one yum repo in it
4.  Promote the content view to Dev

Actual results:

Task will pause at both steps 3 and 4 with an error

Expected results:

Publish and promote complete but with a warning.


Additional info:

Comment 1 Justin Sherrill 2016-03-15 17:02:23 UTC
Created redmine issue http://projects.theforeman.org/issues/14207 from this bug

Comment 3 Bryan Kearney 2016-03-23 22:03:37 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14207 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|83cc9e0c09de190ef4601659905c36654997e704.

Comment 5 Og Maciel 2016-04-06 20:19:44 UTC
I was able to properly verify this issue by following the recommended steps provided in the original issue. Verified on Satellite 6.2.0 SNAP 6.2

Comment 7 errata-xmlrpc 2016-07-27 09:27:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.