Bug 1317976 - deleting a puppet module from product results in failed task
Summary: deleting a puppet module from product results in failed task
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.1.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 16:26 UTC by Chris Duryee
Modified: 2019-04-01 20:27 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-02 21:44:50 UTC


Attachments (Terms of Use)

Description Chris Duryee 2016-03-15 16:26:03 UTC
Description of problem:

If you remove a puppet module from a repo associated with a product, the removal will be successful but the MetadataGenerate task will not complete.


Version-Release number of selected component (if applicable): 6.1.8 snap 1


How reproducible: every time


Steps to Reproduce:
1. create a product with a puppet repo
2. add one module to repo
3. remove module

Actual results: module removal is successful, but MetadataRegenerate task fails (need to view task failure in task list)


Expected results: no failed tasks


Additional info: This does not affect functionality. The reason why it fails is because the product's repo is not associated with an environment, since it's the repo associated with the product.

I believe this is already fixed in Satellite 6.2 due to the addition of an additional puppet distributor on all puppet repos. I am leaving as NEW though so a developer can verify.

Comment 2 Brad Buckingham 2016-05-02 21:44:50 UTC
I ran several tests with Satellite 6.2 Beta (Snap 9.x) and was unable to reproduce this issue.  Going to close it based on discussion with Chris.


Note You need to log in before you can comment on or make changes to this bug.