Bug 1317986 - Failed pulp tasks are not resumable.
Summary: Failed pulp tasks are not resumable.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Orchestration
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1218378 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 17:14 UTC by Justin Sherrill
Modified: 2019-09-26 14:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:27:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 14209 None None None 2016-04-22 17:01:14 UTC

Description Justin Sherrill 2016-03-15 17:14:36 UTC
Partially introduced in https://github.com/Katello/katello/pull/5567
a user is no longer able to 'resume' a failed pulp task.  The task never gets restarted in pulp.  The task seems to resume in dynflow, but is never restarted in pulp.

Its not the easiest thing to actually reproduce without introducing an exception in pulp via a code change.

Comment 1 Justin Sherrill 2016-03-15 17:14:38 UTC
Created from redmine issue http://projects.theforeman.org/issues/14209

Comment 2 Justin Sherrill 2016-03-15 17:14:40 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 4 Bryan Kearney 2016-03-23 18:07:06 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14209 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|86de63973edd329123f864b8f9feee6d6ee08af9.

Comment 7 Tazim Kolhar 2016-04-03 11:52:34 UTC
please provide verification steps

Thanks !!

Comment 8 sthirugn@redhat.com 2016-04-22 18:15:02 UTC
Assigned to Sachin as per the morning meeting discussion as rplevka will be PTO next week

Comment 11 Kedar Bidarkar 2016-04-25 09:59:37 UTC
This will be hard to verify directly. Will be marking this as VERIFIED.

Please re-open this bug if this issue is seen again.


Also this bug will be tested if we find an easy way to verify this bug.

Comment 12 Ivan Necas 2016-04-26 13:27:55 UTC
*** Bug 1218378 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2016-07-27 09:27:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Comment 15 Justin Sherrill 2017-02-06 13:43:16 UTC
clearing needinfo


Note You need to log in before you can comment on or make changes to this bug.