Bug 1318034 - rabl error viewing details of a guest host
Summary: rabl error viewing details of a guest host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Og Maciel
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-15 19:29 UTC by Tom McKay
Modified: 2019-09-26 15:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:06:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
vmware type (150.71 KB, image/png)
2016-07-21 13:40 UTC, Og Maciel
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14220 None None None 2016-04-22 16:11:19 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Tom McKay 2016-03-15 19:29:01 UTC
The subscription facet attempts to include the parent hypervisor name, referring to host.name which errors as not existing.

To reproduce, visit a guest's details page in UI.

Comment 1 Tom McKay 2016-03-15 19:29:04 UTC
Created from redmine issue http://projects.theforeman.org/issues/14220

Comment 3 Bryan Kearney 2016-03-16 20:07:07 UTC
Upstream bug assigned to tomckay@redhat.com

Comment 4 Bryan Kearney 2016-03-17 14:07:12 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14220 has been closed
-------------
Thomas McKay
Applied in changeset commit:katello|e4dbe15efaafc2304cdf31641792cb86ef052142.

Comment 5 Tom McKay 2016-03-17 20:20:09 UTC
The bug prevented visiting the content host page at all. This bug allows the api call to generate json.

Comment 7 Og Maciel 2016-07-21 13:40:32 UTC
Created attachment 1182509 [details]
vmware type

Type shows vmware

Comment 8 Og Maciel 2016-07-21 13:42:50 UTC
To verify this issue:

* Configure the satellite with virt-who
* Register the Satellite as a new guest off the hypervisor
* Visit the Content Host page, select the Satellite
* If you can see the Details tab (default), then the issue is fixed

Verified by QE

Comment 10 errata-xmlrpc 2016-07-27 09:06:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.