Bug 1318045 - Incorrect keymap when decrypting encrypted partitions
Summary: Incorrect keymap when decrypting encrypted partitions
Status: CLOSED DUPLICATE of bug 1331834
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
: 1332296 (view as bug list)
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-15 20:31 UTC by Giulio 'juliuxpigface'
Modified: 2016-06-03 04:18 UTC (History)
22 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-03 04:18:06 UTC


Attachments (Terms of Use)
/var/log/anaconda/* (780.00 KB, application/x-tar)
2016-05-20 12:20 UTC, Petr Schindler
no flags Details
IT layout: /var/log/anaconda/* (from Workstation-Live) (775.50 KB, application/x-tar)
2016-05-24 20:01 UTC, Giulio 'juliuxpigface'
no flags Details
IT layout: /tmp/* (from Workstation-netinst) (2.73 MB, application/x-tar)
2016-05-24 20:26 UTC, Giulio 'juliuxpigface'
no flags Details
ks-script-_gzecil4.log extracted from anaconda.tar (73 bytes, text/plain)
2016-06-02 22:01 UTC, Brian Lane
no flags Details
packaging.log extracted from anaconda.tar (216.93 KB, text/plain)
2016-06-02 22:01 UTC, Brian Lane
no flags Details
dnf.log extracted from anaconda.tar (168.93 KB, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
ks-script-33lfaiop.log extracted from anaconda.tar (469 bytes, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
anaconda.log extracted from anaconda.tar (27.76 KB, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
dnf.rpm.log extracted from anaconda.tar (188.83 KB, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
storage.log extracted from anaconda.tar (5.55 KB, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
journal.log extracted from anaconda.tar (17 bytes, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
ks-script-1wm1931c.log extracted from anaconda.tar (51.24 KB, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
program.log extracted from anaconda.tar (104.74 KB, text/plain)
2016-06-02 22:02 UTC, Brian Lane
no flags Details
anaconda.log from French install of Fedora-Workstation-Live-x86_64-24-20160531.n.0.iso (30.97 KB, text/plain)
2016-06-02 22:50 UTC, Adam Williamson
no flags Details
program.log (114.17 KB, text/plain)
2016-06-02 22:51 UTC, Adam Williamson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1324026 None None None Never

Internal Trackers: 1324026

Description Giulio 'juliuxpigface' 2016-03-15 20:31:21 UTC
Description of problem:
I installed Fedora 24 selecting the Italian language and the Italian keymap. I  encrypted the partitions of the new system, choosing Fedor@ as password.

The encryption passphrase entered during installation does not work on boot of the installed system. That's because the layout is the standard one (US) and not the one I chose during the installation (IT).

The compose is "Fedora_24_Alpha_1.1", and I've hit the issue with both Workstation and KDE ISOs.

The component is just a guess, I don't know if the problem is related to Anaconda.

Version-Release number of relevant components:
anaconda-24.13-1.fc24.x86_64
systemd-229-6.fc24.x86_64
dracut-044-18.git20160108.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot the installer.
2. On the Welcome screen, choose a non-English European language, such as Italian, and click Continue.
3. Click INSTALLATION DESTINATION, and check Encrypt my data.
4. Choose the following passphrase (the "@" character is located on a different position on Italian keyboards): Fedor@
5. Use the same password for "root" nor for another user account.
6. Complete the installation, making sensible choices when Anaconda requires the user's interaction.
7. Boot the installed system.

Actual results:
1. The encryption keymap is the standard one (US).
2. The layout actually changes during the boot, in the following steps. For instance, gnome-initial-setup and sddm know that the user chose the Italian language.

Expected results:
1. The encryption keymap should be the one chosen by the user.

Additional info:
I'm testing with qemu-kvm, but I don't think it's relevant, since I'm pretty sure things were working as expected in the past.

Comment 1 Fedora Blocker Bugs Application 2016-03-15 20:34:05 UTC
Proposed as a Blocker for 24-final by Fedora user juliuxpigface using the blocker tracking app because:

 this bug seems to violate the "2.4.2 Keyboard layout configuration" for Fedora 24 Final.

"If a particular keyboard layout has been configured for the system, that keyboard layout must be used:
- when unlocking encrypted storage volumes during boot"

Reference:
https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria#keyboard-layout-configuration

Comment 2 David Shea 2016-03-15 21:48:13 UTC
anaconda is setting KEYMAP="it" in /etc/vconsole.conf in both the root filesystem and the initrd.

Comment 3 Dan Mossor [danofsatx] 2016-03-29 16:57:50 UTC
I'm not sure about this one - I vote for further testing.

Comment 4 Kamil Páral 2016-03-29 17:38:06 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedBlocker (Final) - as described, this is a clear violation of "If a particular keyboard layout has been configured for the system, that keyboard layout must be used: ... When unlocking encrypted storage volumes during boot"
https://fedoraproject.org/wiki/Fedora_24_Final_Release_Criteria#Keyboard_layout_configuration

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-29

Comment 5 Adam Williamson 2016-03-29 18:00:48 UTC
For the record, https://bugzilla.redhat.com/show_bug.cgi?id=681250 was mentioned in the blocker review discussion, but this does not appear to be a case of that. Italian is not a 'switched' layout, just a Latin QWERTY variant, so it should indeed be used when entering the encryption passphrase.

Comment 6 Giulio 'juliuxpigface' 2016-04-08 20:36:17 UTC
I've installed a qemu-kvm guest from "Fedora-Workstation-netinst-x86_64-24-20160407.n.2.iso" and I can't reproduce the issue anymore.

It seems fixed, but I'll test with lives as soon as possible (in order to see what happens there).

Comment 7 Giulio 'juliuxpigface' 2016-04-21 21:27:27 UTC
Ok... This is interesting...

These days, I've been testing the compose 20160419. The issue is always reproducible with the Workstation Live, but it's not with the Workstation Netinstall.

I used the same password (Fedor@) and the very same layout (Italian).

There is something different with the Live, which triggers the issue (or does not set the keymap correctly).

Comment 8 David Shea 2016-05-02 19:42:48 UTC
*** Bug 1332296 has been marked as a duplicate of this bug. ***

Comment 9 Adam Williamson 2016-05-19 22:53:15 UTC
I confirm this, exactly as Giulio describes it, with today's F24 Workstation live. The 'us' keymap is definitely active when decrypting the disk; once decryption is complete and you reach a tty, 'it' is definitely active.

I get the graphical decryption prompt, in case it makes any difference.

Thinking about it, surely this stage must be handled by dracut? Since it's the root partition that's encrypted, nothing on it can be used (obviously) for the decryption process. On that note, I notice that /boot/initramfs-4.5.4-300.fc24 contains no /etc/vconsole.conf in my affected install. Let's see if I can reproduce Giulio's success with the netinst image, and see if there's a /etc/vconsole.conf in the initramfs in that case...

Comment 10 Adam Williamson 2016-05-19 23:12:39 UTC
yep, bingo. Indeed it works for me with the netinst, and indeed the initramfs for that install contains a /etc/vconsole.conf . So I think that's the difference: /etc/vconsole.conf is not winding up in the initramfs after a live install, it does after a traditional install. I don't know what the cause of that is, and this may have to get reassigned to dracut or something, but it's definitely not systemd's fault.

Comment 11 Kamil Páral 2016-05-20 08:04:35 UTC
Could somebody who reproduced this please attach logs?

Comment 12 Petr Schindler 2016-05-20 12:20 UTC
Created attachment 1159893 [details]
/var/log/anaconda/*

I tried this with Czech keyboard layout, US was used during decryption but cz in gdm. You can find tar of the whole /var/log/anaconda attached.

Comment 13 Kamil Páral 2016-05-23 13:03:20 UTC
Petr, one of cz or cz-qwerty layouts is a dual layout (together with us), so in that case having a default us layout in plymouth would not be a bug. (Adam, do you remember how to recognize whether it's a single or a dual layout?). I think it would be best to attach logs for the reported problem - "it" layout. It seems we would need logs from both live and netinst install, to compare why there's no /etc/vconsole.conf initramfs in one of those cases.

Comment 14 Giulio 'juliuxpigface' 2016-05-24 20:01 UTC
Created attachment 1161196 [details]
IT layout: /var/log/anaconda/* (from Workstation-Live)

I'm attaching files from /var/log/anaconda. They are coming from an installation of "Fedora-Workstation-Live-x86_64-24-20160524.n.0.iso" on qemu-kvm, where the bug is fully reproducible.

I'm also preparing another guest from today's netinst. I'll upload those other logs as soon as possible.

Comment 15 Giulio 'juliuxpigface' 2016-05-24 20:26 UTC
Created attachment 1161198 [details]
IT layout: /tmp/* (from Workstation-netinst)

I'm attaching relevant files from /tmp/.

They are coming from a session of "Fedora-Workstation-netinst-x86_64-24-20160524.n.0.iso" on qemu-kvm, after the installation of a new guest. 

As noted before, this is the case where the bug is not reproducible.

Comment 16 Pravin Satpute 2016-05-25 06:59:58 UTC
Just a guess..Does there any packages get pulled by netinstall during the process, which are not available to in live?

Comment 17 Adam Williamson 2016-05-25 14:18:23 UTC
No, I don't think so. We already know basically what's going on: /etc/vconsole.conf from the installed system does not make it into the initramfs in live installs. It's most likely some kind of ordering issue in terms of when that file gets written vs. when the initramfs gets created, or a difference in the settings for dracut, or something along those lines.

Comment 18 Brian Lane 2016-06-02 22:01:45 UTC
Created attachment 1164236 [details]
ks-script-_gzecil4.log extracted from anaconda.tar

Comment 19 Brian Lane 2016-06-02 22:01:53 UTC
Created attachment 1164237 [details]
packaging.log extracted from anaconda.tar

Comment 20 Brian Lane 2016-06-02 22:02:00 UTC
Created attachment 1164238 [details]
dnf.log extracted from anaconda.tar

Comment 21 Brian Lane 2016-06-02 22:02:07 UTC
Created attachment 1164239 [details]
ks-script-33lfaiop.log extracted from anaconda.tar

Comment 22 Brian Lane 2016-06-02 22:02:14 UTC
Created attachment 1164240 [details]
anaconda.log extracted from anaconda.tar

Comment 23 Brian Lane 2016-06-02 22:02:22 UTC
Created attachment 1164241 [details]
dnf.rpm.log extracted from anaconda.tar

Comment 24 Brian Lane 2016-06-02 22:02:30 UTC
Created attachment 1164242 [details]
storage.log extracted from anaconda.tar

Comment 25 Brian Lane 2016-06-02 22:02:37 UTC
Created attachment 1164243 [details]
journal.log extracted from anaconda.tar

Comment 26 Brian Lane 2016-06-02 22:02:45 UTC
Created attachment 1164244 [details]
ks-script-1wm1931c.log extracted from anaconda.tar

Comment 27 Brian Lane 2016-06-02 22:02:53 UTC
Created attachment 1164245 [details]
program.log extracted from anaconda.tar

Comment 28 Adam Williamson 2016-06-02 22:50 UTC
Created attachment 1164284 [details]
anaconda.log from French install of Fedora-Workstation-Live-x86_64-24-20160531.n.0.iso

bcl said the other attached logs were not from live installs, so here's mine. I installed in French, with encrypted root, and verified that there's a /mnt/sysimage/etc/vconsole.conf but no etc/vconsole.conf in the initramfs in /mnt/sysimage/boot .

Comment 29 Adam Williamson 2016-06-02 22:51 UTC
Created attachment 1164285 [details]
program.log

Comment 30 Adam Williamson 2016-06-03 04:18:06 UTC

*** This bug has been marked as a duplicate of bug 1331834 ***


Note You need to log in before you can comment on or make changes to this bug.