Bug 1318066 - Update katello-rhsm-consumer for atomic
Summary: Update katello-rhsm-consumer for atomic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1321771
TreeView+ depends on / blocked
 
Reported: 2016-03-15 23:30 UTC by Partha Aji
Modified: 2019-09-26 17:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:06:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14223 None None None 2016-04-22 16:19:02 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Partha Aji 2016-03-15 23:30:38 UTC
The mechanism used by Katello to determine if a host is atomic is flawed at the provisioning time. 
https://github.com/Katello/puppet-certs/blob/master/templates/rhsm-katello-reconfigure.erb#L27 
Katello checks for  
<pre>
if [ -e "/run/ostree-booted" ] at the provisioning time, which doesnot exist.
then
  #atomic setup
</pre>

This needs to be  replaced with

<pre>
grep -i 'Atomic Host' /etc/os-release 2>&1> /dev/null
 if [ $? -eq 0 ]
 then
   #atomic setup
</pre>

Comment 1 Partha Aji 2016-03-15 23:30:40 UTC
Created from redmine issue http://projects.theforeman.org/issues/14223

Comment 2 Partha Aji 2016-03-15 23:30:43 UTC
Upstream bug assigned to paji@redhat.com

Comment 4 Bryan Kearney 2016-03-21 18:03:24 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14223 has been closed

Comment 9 Sachin Ghai 2016-04-04 07:00:03 UTC
Ok, I confirmed with dev (Partha) on iRC, the comment8 covered everything required for bz. And IS_ATOMIC var is set by template.

Based on that conversation and comment 8, moving this to verified.

Comment 12 errata-xmlrpc 2016-07-27 09:06:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.