Bug 1318137 - Increase CDN URL characters length (>255) to contain ISS exported directory path
Summary: Increase CDN URL characters length (>255) to contain ISS exported directory path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Settings
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Chris Duryee
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-16 07:35 UTC by Jitendra Yejare
Modified: 2019-09-26 13:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:06:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot Attached (139.80 KB, image/png)
2016-03-16 07:35 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 14329 Normal Closed unable to use a CDN url longer than 255 chars 2019-12-19 16:34:34 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jitendra Yejare 2016-03-16 07:35:53 UTC
Created attachment 1136878 [details]
Screenshot Attached

Description of problem:
The error [An error occurred saving the URL: Validation failed: Repository url is too long (maximum is 255 characters)] while updating CDN URL for ISS exported directory path having more than 255 characters.
E.g: http://qeblade36.rhq.lab.eng.bos.redhat.com/pub/export/Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Virtualization_Agents_for_RHEL_6_Server_RPMs_x86_64_6Server/Default_Organization/Library/content/dist/rhel/server/6/6Server/x86_64/rhev-agent/3/os/

Version-Release number of selected component (if applicable):
Satellite 6.2 Snap 3

How reproducible:
Always

Steps to Reproduce:
1. In upstream satellite, Export a redhat repository which path should have more than 255 characters.
2. In downstream satellite, Attempt to update CDN URL in subscription page with exported directory location of step1 which has more that 255 characters.
Note: Example provided in description.

Actual results:
The following error is raised by CDN URL:
An error occurred saving the URL: Validation failed: Repository url is too long (maximum is 255 characters)

Expected results:
Increase the length of CDN URL to contain url having more that 255 chars.

Additional info:

Comment 2 Chris Duryee 2016-03-23 14:32:03 UTC
The patch will update this to 1024 char.

For the test data given in comment #0, typically you'd want to use "http://qeblade36.rhq.lab.eng.bos.redhat.com/pub/export/Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Virtualization_Agents_for_RHEL_6_Server_RPMs_x86_64_6Server/Default_Organization/Library/", so the "content/dist..." part gets appended to the end.

Comment 3 Bryan Kearney 2016-03-23 16:04:16 UTC
Upstream bug component is Settings

Comment 4 Bryan Kearney 2016-03-23 20:04:17 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/14329 has been closed
-------------
Chris Duryee
Applied in changeset commit:katello|16ed3162f23415fe2184deee616036626fbce3a8.

Comment 6 Jitendra Yejare 2016-03-31 07:39:41 UTC
Verified this in Sat 6.2 snap 6.0.

The issue is no more reproducible and fixed.

I see the CDN URL is taking more than 255 characters and not throwing any error.

So changing the status as Verified.

Comment 9 errata-xmlrpc 2016-07-27 09:06:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.