Bug 131816 - "Select monitor" dialog is not friendly
"Select monitor" dialog is not friendly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks: FC3Target FC3BugWeekQA
  Show dependency treegraph
 
Reported: 2004-09-05 02:04 EDT by John Reiser
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.0.19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 13:12:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-09-05 02:04:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
Note this is FC3-re0903.0-i386.

My monitor is Sony Multiscan 15sf which handles 1024x768 @75Hz, but
has no DDC, so looks like Unprobed Monitor.  During firstboot, the
display begins 800x600, thousands of colors, and a Select Monitor
button.  Selecting Sony Multiscan 15sf, and OKing that selection, does
not change the Select Monitor button to "Sony Multiscan 15sf".  Also,
when I changed the resolution to 1024x768 first, before Select
Monitor, then the dialog set the resolution back to 800x600 even
though the monitor can handle the 1024x768 that I chose.  So I had to
change twice from 800x600 to 1024x768.

Version-Release number of selected component (if applicable):
firstboot-1.3.20-1

How reproducible:
Didn't try

Steps to Reproduce:
1. firstboot with a monitor that does not have DDC.
2. Change from default 800x600 to 1024x768.
3. Change from Select Monitor to Sony Multiscan 15sf
    

Actual Results:  Button remains "Select Monitor" instead of changing
its label to the monitor that was selected.  Also, resolution is
restored to 800x600 despite the user's earlier change to 1024x768
(which the monitor can handle, and the database even agrees: upto to
64KHz horiz freq, up to 120Hz vertical refresh.)

Expected Results:  Once the user selects a monitor, then that monitor
should appear on the button, instead of "Select Monitor".  If the
selected monitor supports the selected resolution, then the Resolution
should not be changed back to the original 800x600.

Additional info:
Comment 1 Paul Nasrat 2004-09-07 12:59:29 EDT
As regards the layout it is a bit confusing as the monitorlabel should
have been changing (below the monitor) but that's non-obivious.  I'm
just doing some changes now:

http://people.redhat.com/pnasrat/screenshot-0004.png

I've a few more things to do should build new package tomorrow first
thing.
Comment 2 Paul Nasrat 2004-09-10 12:54:03 EDT
1.0.19 has a better ui.

Note You need to log in before you can comment on or make changes to this bug.