Bug 131818 - Default install using different locale has english OpenOffice, Firefox and Mozilla
Default install using different locale has english OpenOffice, Firefox and Mo...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-05 05:42 EDT by David Nielsen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 05:35:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2004-09-05 05:42:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
Since OOo no longer depends on the i18n component, it no longer
respects LANG, displaying an english interface to a person who has in
the installer expressed desire to use another locale (in my case
Danish), they will expect all applications to use that language.

The list of offender on a net install of Development currently is:

OpenOffice, Firefox and Mozilla - all of which default to english

I suspect Thunderbird would have the same problem but I honestly
haven't checked.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select none english locale in Anaconda
2. Install

    

Actual Results:  The programs mentioned above use english rather than
the selected language

Expected Results:  Use of selected language

Additional info:
Comment 1 Caolan McNamara 2005-03-18 05:35:58 EST
In rawhide openoffice.org is now split up into seperate langpacks for the
supported languages, e.g. langpack-de for german, so this should be reflected in
the rawhide install now so that installing e.g. under german should suck in the
german langpack and then openoffice.org honours locale in trying to use the
german langpack under the german locale. Falling back to english like most
applications if german langpack is not available.

Note You need to log in before you can comment on or make changes to this bug.