Bug 131819 - yum crashes following latest mirror update
yum crashes following latest mirror update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-05 06:42 EDT by Need Real Name
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-05 21:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-09-05 06:42:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
I ran 'yum update' earlier today (sat september 4) and it updated yum
to new version. I then ran 'yum install' several times and 'yum
update' once more and it completed successfully.

However I later ran 'yum install tcsh', as I do superuser on a
multiuser server and wanted tcsh for some scripts. It finished
sucessful, and as I knew mirrors had been syncd at 3am I ran 'yum
update' again. I recieved the error messages below. I can install
software ok but no updates.

I reverted my yum.conf with my mirrors back to default yum.conf with
redhat server but same message.

As I ran 'yum update' once before with new version of yum without
error, may be a bug with repository?? I am not familiar enough with
fedora(just linux/solaris in general) so I am in no position to speculate.


Version-Release number of selected component (if applicable):
yum 2.1.2, python 2.3.4

How reproducible:
Always

Steps to Reproduce:
1. 'yum update' or 'yum update yum' on latest fedora core 3 test 1
development tree
2. run 'yum update again' to get error
    

Actual Results:  error trace as shown below

Expected Results:  updated packages accordingly

Additional info:

Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3513/3513
Excluding Packages
Excluding Packages from Fedora Core 2.90 - Development Tree
Resolving Dependencies
Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 139, in ?
    main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 94, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 130,
in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 157,
in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
  File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 351,
in _processConflict
    msg = '%s conflicts: %s' % (name,
rpmUtils.miscutils.formatRequire(needname, needversion, flags))
NameError: global name 'name' is not defined
Comment 1 Need Real Name 2004-09-05 06:46:20 EDT
This is my basic /etc/yum.conf. Usually I have mirrors.usc.edu as
default but until problem is resolved I will keep this as is.

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=fedora-release
tolerant=1
exactarch=0
retries=20

[development]
#gpgcheck=1
name=Fedora Core $releasever - Development Tree
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/
#http://mirrors.usc.edu/pub/linux/distributions/fedora/development/i386/
Comment 2 Need Real Name 2004-09-05 19:20:07 EDT
Never mind, bug fixed in yum version 2.1.3

Note You need to log in before you can comment on or make changes to this bug.