Bug 1318220 - CVE-2016-2315 CVE-2016-2324 git: remote code execution via buffer overflow [fedora-all]
Summary: CVE-2016-2315 CVE-2016-2324 git: remote code execution via buffer overflow [f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git
Version: 23
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: pstodulk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: fst_owner=dcafaro
Depends On:
Blocks: CVE-2016-2315, CVE-2016-2324
TreeView+ depends on / blocked
 
Reported: 2016-03-16 10:05 UTC by Andrej Nemec
Modified: 2016-03-30 21:20 UTC (History)
11 users (show)

Fixed In Version: git-2.5.5-1.fc23 git-2.4.11-1.fc22
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-21 01:50:35 UTC


Attachments (Terms of Use)

Description Andrej Nemec 2016-03-16 10:05:26 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When submitting as an update, use the fedpkg template provided in the next
comment(s).  This will include the bug IDs of this tracking bug as well as
the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
fedpkg commit message.

NOTE: this issue affects multiple supported versions of Fedora. While only
one tracking bug has been filed, please correct all affected versions at
the same time.  If you need to fix the versions independent of each other,
you may clone this bug as appropriate.

[bug automatically created by: add-tracking-bugs]

Comment 1 Andrej Nemec 2016-03-16 10:05:33 UTC
Use the following template to for the 'fedpkg update' request to submit an
update for this issue as it contains the top-level parent bug(s) as well as
this tracking bug.  This will ensure that all associated bugs get updated
when new packages are pushed to stable.

=====

# bugfix, security, enhancement, newpackage (required)
type=security

# testing, stable
request=testing

# Bug numbers: 1234,9876
bugs=1317981,1318220

# Description of your update
notes=Security fix for CVE-2016-2315, CVE-2016-2324

# Enable request automation based on the stable/unstable karma thresholds
autokarma=True
stable_karma=3
unstable_karma=-3

# Automatically close bugs when this marked as stable
close_bugs=True

# Suggest that users restart after update
suggest_reboot=False

======

Additionally, you may opt to use the bodhi web interface to submit updates:

https://bodhi.fedoraproject.org/updates/new

Comment 2 Fedora Admin XMLRPC Client 2016-03-16 18:23:57 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Jan Kurik 2016-03-17 09:12:41 UTC
Info about this bug on seclists.org: http://seclists.org/oss-sec/2016/q1/645

Comment 4 H. Peter Anvin 2016-03-17 22:49:52 UTC
Upstream maintenance releases are now available as far as 2.4:

http://marc.info/?l=git&m=145824889421350

The latest maintenance release Git v2.7.4 is now available at the
usual places.  The same set of bugfix patches from the current
'master' have been backported to older maintenance tracks and are
available as v2.4.11, v2.5.5 and v2.6.6.  These are to fix a heap
corruption / buffer overflow bug and users are strongly encouraged
to upgrade.  The fix has already been in the release candidate
v2.8.0-rc3 as well.

Would it be unreasonable to ask for an uprev to 2.7.4 in Fedora 23?

Comment 5 David Woodhouse 2016-03-18 00:44:09 UTC
Is anyone working on this? I've just done 2.5.5 scratch builds for my own (users') use; I'm happy to do a proper update for F23 and F22...

 https://koji.fedoraproject.org/koji/taskinfo?taskID=13378702

Comment 6 David Woodhouse 2016-03-18 01:32:28 UTC
I've triggered a rawhide build of 2.7.4. Pushed 2.4.11 and 2.5.5 to git for f22 and f23 respectively, but will wait until tomorrow (well, later today) to see if anyone screams before I actually tag and build them.

Comment 7 pstodulk 2016-03-18 09:10:58 UTC
Thanks David. Yes, I was working on this earlier of the day, but freeze on testing with backported patches. I was sleeping already when You ask here so thanks for help.

I plan reabse in rawhide & F24 to v2.8.0 (release will be outside soon probably). Even with patched v2.7.4, the v2.8.0 seems better.

Comment 8 Fedora Update System 2016-03-18 13:22:53 UTC
git-2.5.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6554eff611

Comment 9 Fedora Update System 2016-03-18 13:24:03 UTC
git-2.4.11-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cee7647200

Comment 10 Fedora Update System 2016-03-18 23:53:52 UTC
git-2.4.11-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cee7647200

Comment 11 Fedora Update System 2016-03-19 01:23:24 UTC
git-2.5.5-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6554eff611

Comment 12 Fedora Update System 2016-03-21 01:50:30 UTC
git-2.5.5-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-03-30 21:20:49 UTC
git-2.4.11-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.