Bug 131827 - /var/mailman/Mailman/Default.py has wrong location for sendmail
Summary: /var/mailman/Mailman/Default.py has wrong location for sendmail
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mailman
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-05 12:57 UTC by jonathan baron
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-09-07 15:09:53 UTC


Attachments (Terms of Use)

Description jonathan baron 2004-09-05 12:57:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a3)
Gecko/20040902

Description of problem:
Mailman would not send mail until I added
SENDMAIL_CMD = '/usr/sbin/sendmail'
to /var/mailman/Mailman/mm_cfg.py
Default.py had it as /usr/lib/sendmail.
That file doesn't exist, although there is a
link from /usr/lib/sendmail.sendmail to /sbin


Version-Release number of selected component (if applicable):
rpm mailman-2.1.5-7

How reproducible:
Always

Steps to Reproduce:
1. install mailman
2. try to use it
3.
    

Actual Results:  instructions are somewhat incomplete, but some tinkering
led to everything working except sending mail


Expected Results:  sent mail


Additional info:

Comment 1 John Dennis 2004-09-07 15:09:53 UTC
On Red Hat systems there are two MTA's available, sendmail and
postfix. Because these two MTA'a share files when installed both
utilize the alternatives mechanism and thus require your MTA to be
selected. There is a configuration applet to do this
(system-switch-mail) or you can invoke "/usr/sbin/alternatives
--config mta" directly. After your MTA is configured then
/usr/lib/sendmail will exist.

I cannot explain why your MTA was not configured, but this is not a
mailman problem. I will however update the mailman INSTALL.REDHAT file
to draw attention to this.

Comment 2 jonathan baron 2004-09-07 19:44:46 UTC
Thanks.  Good idea to add to INSTALL.REDHAT.

My mta was configured on my other computer with Fedora Core 2.
On that one, I upgraded from RH9.  On the one with the problem
I upgraded from FC2 test 2.  Perhaps that was
where the problem was.  (I could not install RH9 because its
kernel would not work with my disk drive, so I started with the
FC2 test2 when the computer was brand new.)



Note You need to log in before you can comment on or make changes to this bug.