Bug 1318376 (glusterfs-3.7.10) - Tracker for glusterfs-3.7.10
Summary: Tracker for glusterfs-3.7.10
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: glusterfs-3.7.10
Product: GlusterFS
Classification: Community
Component: core
Version: 3.7.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vijay Bellur
QA Contact:
URL:
Whiteboard:
Depends On: 1304963 1314366 1317049 1317788 1319989 1320377 1322242
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-16 17:02 UTC by Niels de Vos
Modified: 2016-04-19 07:03 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-19 07:03:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-03-16 17:02:58 UTC
This is the tracker bug for glusterfs-3.7.10. Please add any bugs you hope to get fixed in 3.7.10 as blockers for this bug.

Comment 1 Oleksandr Natalenko 2016-03-21 11:30:26 UTC
Desired memleak-related patches:

===
Soumya Koduri (3):
      rpc: Fix for rpc_transport_t leak
===

Related review: http://review.gluster.org/#/c/13456/

It seems it was merged into master, but wasn't backported to 3.7 branch.

Comment 2 Soumya Koduri 2016-03-21 17:06:20 UTC
(In reply to Oleksandr Natalenko from comment #1)
> Desired memleak-related patches:
> 
> ===
> Soumya Koduri (3):
>       rpc: Fix for rpc_transport_t leak
> ===
> 
> Related review: http://review.gluster.org/#/c/13456/
> 
> It seems it was merged into master, but wasn't backported to 3.7 branch.

Hi Oleksander,

As discussed in http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/14284, this patch resulted in a regression in geo-rep code path and was detected only in 3.7 branch. Though we have respective fixes, since rpc_* related changes are intricate. we have decided to backport them only once we know code is stable in master branch.

Comment 3 Oleksandr Natalenko 2016-03-21 17:38:55 UTC
So, after brief talk with Soumya in IRC, the following patches are considered to be the proper fix (at least, for now):

===
Kotresh HR (2):
      rpc: Connect back only if rpc is not disabled
      changelog/rpc: Fix rpc_clnt_t mem leaks

Soumya Koduri (1):
      rpc: Fix for rpc_transport_t leak
===

Those correspond to the following reviews:

* http://review.gluster.org/#/c/13456
* http://review.gluster.org/#/c/13592
* http://review.gluster.org/#/c/13658

Comment 4 Kaushal 2016-04-19 07:03:58 UTC
This bug is getting closed because a glusterfs-3.7.10 release has been made.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.