Bug 1318408 - /usr/bin/chcat still uses python2
Summary: /usr/bin/chcat still uses python2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-16 19:11 UTC by David Shea
Modified: 2016-03-26 18:02 UTC (History)
3 users (show)

Fixed In Version: policycoreutils-2.5-3.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-26 18:02:45 UTC


Attachments (Terms of Use)

Description David Shea 2016-03-16 19:11:39 UTC
Description of problem:
It looks like chcat is the only thing in policycoreutils-python-utils that still uses python2. I'm not sure if it even needs to, it looks like it's been converted to handle py3 already, so maybe it just needs to switch to python3 in the #! line.

Anyway, policycoreutils-python-utils depends on both python2 and python3. Pick one, please.

Version-Release number of selected component (if applicable):
policycoreutils-python-utils-2.5-2.fc25.x86_64

Comment 1 Petr Lautrbach 2016-03-17 09:10:05 UTC
Thanks for the report. I missed this one script when I changed shebangs from python to python3. It's fixed in policycoreutils-python-utils-2.5-3.fc25.x86_64.rpm

$ rpm -qp --requires policycoreutils-python-utils-2.5-3.fc25.x86_64.rpm
/usr/bin/python3
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libselinux.so.1()(64bit)
libsepol.so.1()(64bit)
libsepol.so.1(LIBSEPOL_1.0)(64bit)
policycoreutils-python3 = 2.5-3.fc25
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rtld(GNU_HASH)

Comment 2 Fedora Update System 2016-03-17 09:31:53 UTC
policycoreutils-2.5-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7768fe733a

Comment 3 Fedora Update System 2016-03-18 14:57:24 UTC
policycoreutils-2.5-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7768fe733a

Comment 4 Fedora Update System 2016-03-26 18:02:43 UTC
policycoreutils-2.5-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.