Bug 1318445 - rhel-osp-director: Configuration errors resulting from tagging nodes with profiles should prevent the deployment from starting.
Summary: rhel-osp-director: Configuration errors resulting from tagging nodes with pro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
: 1263792 1330333 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-16 22:41 UTC by Alexander Chuzhoy
Modified: 2016-12-14 15:28 UTC (History)
12 users (show)

Fixed In Version: python-tripleoclient-5.2.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:28:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Alexander Chuzhoy 2016-03-16 22:41:06 UTC
rhel-osp-director: Configuration errors resulting from tagging nodes with profiles should prevent the deployment from starting.

Environment:

instack-undercloud-2.2.5-1.el7ost.noarch
openstack-ironic-inspector-2.2.4-3.el7ost.noarch
openstack-ironic-conductor-4.2.2-4.el7ost.noarch
python-ironic-inspector-client-1.2.0-6.el7ost.noarch
openstack-ironic-common-4.2.2-4.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch
openstack-ironic-api-4.2.2-4.el7ost.noarch

Steps to reproduce:
1. Deploy undercloud.

2. Assign profiles to nodes using this procedure: http://tripleo.org/advanced_deployment/profile_matching.html#examples-of-introspection-rules
 
3. Start a deployment with mispelling some profile name

Result:
Error: only 0 of 3 requested ironic nodes are tagged to profile control (for flavor control)
Recommendation: tag more nodes using ironic node-update <NODE ID> replace properties/capabilities=profile:control,boot_option:local
Error: only 1 of 2 requested ironic nodes are tagged to profile compute (for flavor compute)                                       
Recommendation: tag more nodes using ironic node-update <NODE ID> replace properties/capabilities=profile:compute,boot_option:local
1 nodes with profile ceph-storage won't be used for deployment now                                                                 
Configuration has 2 errors, fix them before proceeding. Ignoring these errors is likely to lead to a failed deploy.                
Configuration has 1 warnings, fix them before proceeding.                                                                          
Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates     

Expected result:
The deployment shouldn't start.

Comment 1 Mike Burns 2016-04-07 21:14:44 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 2 Lucas Alvares Gomes 2016-05-16 10:25:00 UTC
*** Bug 1330333 has been marked as a duplicate of this bug. ***

Comment 3 Dmitry Tantsur 2016-10-17 09:35:20 UTC
Hi! I was testing OSP 10 the other day, and the error were actually fatal. Fixed?

Comment 6 Dmitry Tantsur 2016-10-17 13:23:34 UTC
*** Bug 1263792 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2016-12-14 15:28:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.