Bug 1318470 - failure to mount persistent overlay when booting live USB
Summary: failure to mount persistent overlay when booting live USB
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-17 00:30 UTC by Chris Murphy
Modified: 2016-05-17 15:13 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-17 15:13:25 UTC


Attachments (Terms of Use)
journal (455.03 KB, text/plain)
2016-03-17 00:30 UTC, Chris Murphy
no flags Details
blkid (1.46 KB, text/plain)
2016-03-17 00:30 UTC, Chris Murphy
no flags Details
dmsetup status (77 bytes, text/plain)
2016-03-17 00:32 UTC, Chris Murphy
no flags Details
f24 workstation beta livecd-tools USB with persistence built in f23 (2.51 KB, text/plain)
2016-05-09 17:40 UTC, satellitgo
no flags Details

Description Chris Murphy 2016-03-17 00:30:30 UTC
Created attachment 1137261 [details]
journal

Description of problem:

The overlay fails to mount during boot, and dmsetup status shows the overlay space available is reset between boots (not persistent). I'm not sure if this is a setup problem with livecd-iso-to-disk or a dracut problem or if this feature is in effect deprecated (the live media still works, just no persistent overlay).


Version-Release number of selected component (if applicable):
livecd-tools-23.2-3.fc23
dracut-044-18.git20160108.fc24

How reproducible:
Always


Steps to Reproduce:
1. Fedora 23 livecd-tools installed, and Fedora-Workstation-Live-x86_64-24_Alpha-5.iso as source
2.   livecd-iso-to-disk --noverify --format --reset-mbr --efi --overlay-size-mb 100 /brick1/downloads/Fedora-Workstation-Live-x86_64-24_Alpha-5.iso /dev/sdb


Actual results:

[    7.645444] localhost dracut-initqueue[540]: mount: /dev/sdb1 is already mounted or /run/initramfs/overlayfs busy
[    7.656169] localhost dracut-initqueue[540]: umount: /run/initramfs/overlayfs: not mounted


Expected results:

Should mount.


Additional info:

The grub.cfg boot param includes:
root=live:UUID=D486-BF04 rd.live.image rd.live.overlay=UUID=D486-BF04

The path+name of the overlay file is
/LiveOS/overlay-LIVE-D486-BF04


Snippets from the journal:

[    7.323769] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@80(main): mount -n -t auto -o ro /dev/disk/by-uuid/D486-BF04 /run/initramfs/live

This is /dev/sdb1 mounted at /run/initramfs/live




    7.625907] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@111(do_live_overlay): '[' -n UUID=D486-BF04 -a -n /LiveOS/overlay-LIVE-D486-BF04 -a -n UUID=D486-BF04 ']'
[    7.627756] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@112(do_live_overlay): mkdir -m 0755 /run/initramfs/overlayfs
[    7.629497] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@113(do_live_overlay): mount -n -t auto UUID=D486-BF04 /run/initramfs/overlayfs
[    7.645444] localhost dracut-initqueue[540]: mount: /dev/sdb1 is already mounted or /run/initramfs/overlayfs busy
[    7.647222] localhost dracut-initqueue[540]:        /dev/sdb1 is already mounted on /run/initramfs/live

Since /dev/sdb1 is already mounted, it fails to mount again at /run/initramfs/overlayfs (different location).


[    7.648992] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@113(do_live_overlay): :
[    7.652435] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@114(do_live_overlay): '[' -f /run/initramfs/overlayfs/LiveOS/overlay-LIVE-D486-BF04 -a -w /run/initramfs/overlayfs/LiveOS/overlay-LIVE-D486-BF04 ']'
[    7.654336] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@121(do_live_overlay): umount -l /run/initramfs/overlayfs
[    7.656169] localhost dracut-initqueue[540]: umount: /run/initramfs/overlayfs: not mounted

Because it's looking for the overlay file only at /run/initramfs/overlayfs and not at /run/initramfs/live it fails to setup the overlay.


[    7.657983] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@121(do_live_overlay): :
[    7.659821] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@124(do_live_overlay): '[' -z '' -o -n '' ']'
[    7.661657] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@125(do_live_overlay): '[' -n '' ']'
[    7.663528] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@127(do_live_overlay): '[' -n UUID=D486-BF04 -a -n /LiveOS/overlay-LIVE-D486-BF04 ']'
[    7.665357] localhost dracut-initqueue[540]: /sbin/dmsquash-live-root@128(do_live_overlay): warn 'Unable to find persistent overlay; using temporary'
[    7.667159] localhost dracut-initqueue[540]: /lib/dracut-lib.sh@72(warn): echo 'Warning: Unable to find persistent overlay; using temporary'
[    7.668969] localhost dracut-initqueue[540]: Warning: Unable to find persistent overlay; using temporary

Comment 1 Chris Murphy 2016-03-17 00:30 UTC
Created attachment 1137262 [details]
blkid

Comment 2 Chris Murphy 2016-03-17 00:32 UTC
Created attachment 1137263 [details]
dmsetup status

The value of live-rw is always 32008 for each boot. It goes up as the live environ is used but goes back to 32008 at boot so yeah definitely not persistent.

Comment 3 Chris Murphy 2016-04-18 17:53:26 UTC
Since the failure is happening in dracut, is it possible the right component here is lorax? livemedia-creator may be naming things on the LiveISO differently than dracut is expecting is my current best guess.

Comment 4 Fedora Blocker Bugs Application 2016-04-23 18:25:56 UTC
Proposed as a Blocker for 24-final by Fedora user chrismurphy using the blocker tracking app because:

 The release-blocking live images must properly support mounting and using a persistent storage overlay for the entire system and/or one for the /home partition.

Comment 5 Tim Flink 2016-05-02 22:06:07 UTC
Discussed during the 2016-05-02 blocker review meeting.

This is accepted per the current criterion which it definitely seems to violate but we note that this whole area has changed a lot with F24 and it may be that persistence is no longer supported. Need to check with developers for clarification

Comment 6 Brian Lane 2016-05-05 15:49:20 UTC
crap. modified wrong bug, sorry for the noise.

Comment 7 Brian Lane 2016-05-05 17:17:18 UTC
This should be fixed in the next build by this patch:

https://github.com/rhinstaller/livecd-tools/commit/f2496cf4602f2e54f26422d13c40a036c697f6ab

Comment 8 Fedora Update System 2016-05-06 00:00:59 UTC
livecd-tools-23.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-16c46e44e1

Comment 9 Fedora Update System 2016-05-06 00:04:59 UTC
livecd-tools-23.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-edcdaedcc0

Comment 10 Fedora Update System 2016-05-06 11:26:29 UTC
livecd-tools-23.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-16c46e44e1

Comment 11 Fedora Update System 2016-05-06 20:54:50 UTC
livecd-tools-23.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-edcdaedcc0

Comment 12 satellitgo 2016-05-09 17:40 UTC
Created attachment 1155407 [details]
f24 workstation beta livecd-tools USB with persistence built in f23

Comment 13 satellitgo 2016-05-09 17:44:40 UTC
Comment on attachment 1155407 [details]
f24 workstation beta livecd-tools USB with persistence built in f23

no changes on reboot not persistent

Comment 14 satellitgo 2016-05-09 20:19:19 UTC
Package: 1:livecd-tools-23.3-1.fc23.x86_64 (/livecd-tools-23.3-1.fc23.x86_64-2)
    Requires: python-imgcreate = 1:23.3-1.fc23
    Installed: 1:python-imgcreate-23.2-3.fc23.x86_64 (installed)
        python-imgcreate = 1:23.2-3.fc23

error message so not tested correctly  (used yumex package installer in cinnamon f23)

Comment 15 satellitgo 2016-05-09 23:07:04 UTC
(In reply to Fedora Update System from comment #8)
> livecd-tools-23.3-1.fc24 has been submitted as an update to Fedora 24.
> https://bodhi.fedoraproject.org/updates/FEDORA-2016-16c46e44e1

livecd-tools-23.3-1.fc24

worked in f24 workstation  got persistent file:  stored wifi/ favorites/ power settings
no error msgs from workstation installer "software"
* satellit  livecd-iso-to-disk --format --reset-mbr --overlay-size-mb 2000 --home-size-mb 2000 --delete-home --unencrypted-home Fedora-Workstation-Live-x86_64-24_Beta-1.4.iso /dev/sdb

Comment 16 Fedora Update System 2016-05-12 07:29:14 UTC
livecd-tools-23.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Kamil Páral 2016-05-16 17:37:24 UTC
verified per bodhi comments

Comment 18 Fedora Update System 2016-05-17 15:13:21 UTC
livecd-tools-23.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.