Bug 131849 - Low Volume from Sound Card
Low Volume from Sound Card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-05 12:36 EDT by Gary F. Alderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 19:12:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary F. Alderson 2004-09-05 12:36:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Since I started playing around with the Linux 2.6 kernel in both SuSE 9
and RedHat Fedora Core 2, I have been have serious problems trying to
get any volume out of my C-Media cm8738 internal sound card. When
testing it, the test signal is only barely perceptible.

SuSE had a short term (do it at every login as root) fix which worked,
but was of course unacceptable, of deleting the /etc/asound.state file
and restarting the alsasound daemon.

After installing Fedora Core 2, I had the same problem. I searched high
and low on the RedHat bugzilla site to no avail. Finally I stumbled upon
http://www.linuxquestions.org/questions/archive/35/2004/08/3/217181

Apparently, the installation creates a /etc/modprobe.conf entries that
apply to all cards using the Intel8x0 sound chip (Intel chipset
motherboards). Here is the simple recommendation that finally works.

> I also agree with jomen about commenting out the lines in your
> etc/modprobe.conf file that pertain to trident. They just don't look
> like they belong there. You should also try commenting out the lines:
> 
> install snd-cmipci /sbin/modprobe --ignore-install snd-cmipci &&
> /usr/sbin/alsactl restore >/dev/null 2>&1 || :
> remove snd-cmipci { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
> /sbin/modprobe -r --ignore-remove snd-cmipci
> 
> Those lines look like they are pointing to "/dev/null" which would
> keep your sound from working. Just add the # sign in front of both of
> those lines and when your computer reads that file it will ignore
> those lines. If that doesn't work you can remove the # sign. Also make
> sure you reboot after changing the file, it might not be necessary but
> it doesn't hurt. I have had times when rebooting solved frustrating
> problems.


Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521 also kernel 2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
1. login to X-Windows and try something with sound.
2. attempt to increase volume using alsamixer
3. try sound card detection
    

Actual Results:  Barely audible sound at full volume.

Expected Results:  One would hope realistic volume. After fixing the
/etc/modprobe.conf everything worked just fine.

Additional info:

This would appear to be a generic alsa installation problem as it
appears in both SuSE and Fedora. Can someone bounce this over to them
as well.
Comment 1 Bastien Nocera 2004-09-19 09:27:05 EDT
ALSA sound volume is saved on shutdown, and restored on bootup.
Try removing the /etc/asound.state file, reboot the machine, and then
modify the volume (unmute what needs to be unmuted) in alsa-mixer.
From then on, the volume level will be the same.

If when you rise the volume for all those tracks, the volume is still
low, it's possible that the bug is in the driver.
Could you let me know the result of those tests?
Comment 2 Gary F. Alderson 2004-09-27 02:11:19 EDT
I have tried deleting /etc/asound.state many times before performing
the fix described above commenting out the lines in
/etc/modprobe.conf. It made no difference. 

To satisfy the request I have done this once more, this time with the
mods shown in the recommendations in my original message commenting
out the lines in /etc/modprobe.conf. Yes it saves the state, but it
did before that too.

Commenting the lines in /etc/modprobe.conf is the first permanent fix
I have found for this problem.
Comment 3 Bastien Nocera 2004-09-30 19:12:56 EDT
> and restarting the alsasound daemon.

There's no ALSA sound daemon, it's all in the kernel.
> that apply to all cards using the Intel8x0 sound chip (Intel
> chipset motherboards).

Why does the explanation show "snd-cmpci" instead of "snd-intel8x0" as
the driver?

> Those lines look like they are pointing to "/dev/null" which would
> keep your sound from working.

No, they mean that the output for alsactl restore goes to /dev/null,
not your sound...

If the sound is too low, increase it using the mixer. I don't see what
else can be done in software (ie. make sure you're using the speaker
output, not the headphones output).

Note You need to log in before you can comment on or make changes to this bug.