Bug 131851 - letter ö (o with two dots) is broken in Bitstream Vera Sans
letter ö (o with two dots) is broken in Bitstream Vera Sans
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Brock Organ
: Reopened
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2004-09-05 12:55 EDT by Toni Willberg
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.2.1-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-01 23:11:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot with missing dot (84.38 KB, image/png)
2004-09-08 13:14 EDT, Toni Willberg
no flags Details
a screenshot without antialiasing (84.38 KB, image/png)
2004-09-08 13:54 EDT, Toni Willberg
no flags Details
screenshot without antialiasing (27.18 KB, image/png)
2004-09-08 13:59 EDT, Toni Willberg
no flags Details

  None (edit)
Description Toni Willberg 2004-09-05 12:55:39 EDT
The letter ö is displayed incorrectly, it shows only one dot instead
of two.

bitstream-vera-fonts-1.10-3 and 1.10-4
Comment 1 Owen Taylor 2004-09-05 13:37:51 EDT
FreeType version? What sizes does this occur for? Have you
changed any of the font settings from their default values?
Comment 2 Toni Willberg 2004-09-05 13:51:05 EDT
Tested on freetype-2.1.9-1 and 2.1.7-4

This happens on sizes 10 and 11. Larger and smaller sizes don't seem
to suffer from the same problem.

The fonts affected are (Bitstream Vera) Sans Roman and Sans Mono.
Seems to work correctly with their Sans Serif face. Quick testing on
some other fonts didn't indicate any other font face being broken this
way.

The "Font Rendering" setting on the Font Preferences gui don't seem to
have any effect on this. I've not played with the font settings in any
other way that I would be aware of myself. :)

I tested with my old workstation (FC2 with updates) and new laptop
(fresh net install of FC development tree).




Comment 3 Owen Taylor 2004-09-07 09:41:52 EDT
Hmmm, what app? If this is happening with "classic" (crufty)
monochrome X fonts, it's not that suprising, and basically a
WONTFIX; autohinting for monochrome rendering isn't something we are
going to put any effort into.

(We accidentally shipped X with the TT interpreter on in FC1,
so this may have "regressed" since then.)
Comment 4 Toni Willberg 2004-09-07 10:07:30 EDT
All "modern" apps, including gedit.

Comment 5 Owen Taylor 2004-09-07 10:22:22 EDT
Can't reproduce. To check if you've changed font settings, can
you try to reproduce this on a newly created account? 
Comment 6 Toni Willberg 2004-09-07 11:07:19 EDT
Happens on two separate installations . The other has been just
installed, so it's reproducable with "clean" accounts too.

And just to clarify, it's only the small ö, capital Ö looks fine.

Is there something I could do to debug this myself?
Comment 7 Owen Taylor 2004-09-07 11:19:59 EDT
Can you give me an exact sequence of steps to reproduce for
a clean account on a clean install? (Of rawhide/FC3testN, preferably)

Most likely, the problem is that the hinting code in FreeType
isn't working right for some particular combination of font and
rendering options. There's no real debug other than diving into
the hinting code and making it better.


Comment 8 Toni Willberg 2004-09-07 12:01:03 EDT
Ok, the steps are very simple:

- log in as normal, newly created user
- start gedit
- type (or copy&paste) character ö (o with two dots)
- on gedit: Edit -> Preferences -> Fonts & Colors
-> Font: uncheck "Use default theme font"
-> Select Editor Font: Bitstream Vera Sans Roman size 10 or size 9

I've tested with 1280x and 1024x screen resolutions, even if it
shouldn't matter much.

Comment 9 Owen Taylor 2004-09-07 13:36:45 EDT
Following those instructions, I can't reproduce with a recent
version of Rawhide.

Can you give rpm -q and rpm -V output for freetype and fontconfig?
Comment 10 Toni Willberg 2004-09-07 14:08:27 EDT
fontconfig-2.2.3-2
freetype-2.1.9-1


"rpm -V fontconfig freetype" gives no output, assuming everything is
ok with the package.

Comment 11 Owen Taylor 2004-09-08 11:10:53 EDT
OK, I'm pretty stumped on this one. One final thing ... can you
provide a screenshot of the wrong rendering? That might give me
some new idea.
Comment 12 Toni Willberg 2004-09-08 13:14:03 EDT
Created attachment 103595 [details]
screenshot with missing dot

Attached screenshot.

Notice the text in Gedit, and the subject line of the opened mail message.
Comment 13 Owen Taylor 2004-09-08 13:24:00 EDT
Ah, first you have subpixel antialiasing on. This means either:

 A) You changed font properties

or:

 B) You aren't running GNOME (outside of GNOME, subpixel antialiasing
    may be turned on automatically if you have a LCD monitor)

Turning that on, I can reproduce.
Comment 14 Toni Willberg 2004-09-08 13:54:38 EDT
Created attachment 103598 [details]
a screenshot without antialiasing

Happens without subpixel antialiasing too (see new screenshot).

- both of my computers do have a LCD display, and the desktop one is connected
via DVI interface
- on both computers I also do run Gnome

I don't have any CRTs at home to test this with.
Comment 15 Toni Willberg 2004-09-08 13:56:20 EDT
Comment on attachment 103598 [details]
a screenshot without antialiasing

sorry, attached wrong file... new one coming :/
Comment 16 Toni Willberg 2004-09-08 13:59:11 EDT
Created attachment 103599 [details]
screenshot without antialiasing

The correct new screenshot.
Comment 17 Owen Taylor 2004-09-08 14:18:49 EDT
That's without anti-aliasing at all. I don't care about that.
Comment 18 Toni Willberg 2004-09-08 14:29:24 EDT
Now I don't follow what you mean. The last screenshot was taken with
the default settings.

Unless someone figures out how to debug this more, I guess we'll just
leave the bug open for now and wait for others to confirm the behaviour.

Comment 19 Owen Taylor 2004-09-08 14:32:55 EDT
A) The last screenshot was *not* taken with the default settings. 

B) Note:

   "Turning that on, I can reproduce."

   three or four comments ago.

It doesn't mean that I'll look at it any time soon, I'm pretty
busy and it doesn't promise to be easy. But with the ability to 
reproduce, comes the ability to debug.
Comment 20 Christian Guelpen 2006-02-26 17:27:35 EST
I noticed the same thing. It happens with Subpixel Rendering turned on and also
any Form of Hinting turned on. It is not only Vera Sans, it happens with other
fonts, too (Arial for example). Depending on the font the letters ü, ö, ä
(German umlauts) are displayed with only one dot instead of two.
It seems that it only happens when using RGB or BGR, VRGB and VBGR are fine.
Subpixel Rendering is very nice on LCDs and the missing dots are quite annoying.
It seems this bug is very old, has there been any progress? I am using the
latest development packages (Fedora 5)
Comment 21 Pierre Ossman 2006-08-28 06:46:35 EDT
Problem exists here as well. I got the following from the DejaVu-fonts list:

Hi,

this problem is a bug in FreeType-2.2.1. It is fixed in the FreeType 
CVS, so you could either compile the cvs version or ask the person 
who's in charge of the freetype packages to apply the patches at 
http://lists.nongnu.org/archive/html/freetype-devel/2006-06/msg00057.html 
which will fix this issue (and another hinting issue as well)

Greetings
Ben


On Saturday 05 August 2006 02:02, Nicolas Mailhot wrote:
> > -------- Message transféré --------
> >
>> > > De: Pierre Ossman <drzeus-list@drzeus.cx>
>> > > À: fonts@gnome.org
>> > > Sujet: umlaut broken
>> > > Date: Sat, 05 Aug 2006 00:12:25 +0200
>> > >
>> > > Red Hat seems to have changed from having Luxi Mono as the default
>> > > monospace font to Bitstream Vera Sans Mono. As I am a Swedish user
>> > > I noticed the misrendering seen in the included file.
>> > >
>> > > The application in the image is OpenOffice.org write which seems to
>> > > use greyscale anti-aliasing. The same effect can be seen with GTK+
>> > > applications, where I use subpixel anti-aliasing.
>> > >
>> > > I have no idea which hinter is being used.
>> > >
>> > > Only o-umlaut seem to suffer from the problem (at 10 pt at least).
>> > >
>> > > My system is Fedora Rawhide.
>> > >
>> > > freetype-2.2.1-3
>> > > libXft-2.1.10-1.1
>> > > fontconfig-2.3.95-6
>> > >
>> > > Rgds
>> > > Pierre
Comment 22 Pierre Ossman 2006-08-30 15:29:22 EDT
Bug still present, so please reopen.
Comment 23 Behdad Esfahbod 2006-08-31 00:59:06 EDT
I'm investigating.
Comment 24 Behdad Esfahbod 2006-09-11 17:18:25 EDT
The bug is indeed fixed in freetype CVS.  Someone should identify the right
change that fixed it.  It's not the patches that were earlier pointed to here.
Comment 25 Pierre Ossman 2006-11-03 06:21:33 EST
Any progress on this?
Comment 26 Behdad Esfahbod 2006-11-06 17:20:25 EST
(In reply to comment #25)
> Any progress on this?

Not really.  I probably will wait until the next FreeType release comes out.
Comment 27 Matthias Clasen 2007-04-01 23:11:27 EDT
I believe the freetype version we ship in rawhide has this fixed.

Please reopen if you still see it.
Comment 28 Peter Bieringer 2007-04-11 05:15:00 EDT
Can one please push the fixed freetype version also to FC6, which has the same
problem or is it necessary to clone the bug?
Current FC6 version: freetype-2.2.1-16.fc6

Note You need to log in before you can comment on or make changes to this bug.