Bug 1318581 - option "-T" for multipath(8) need to be documented in man page
Summary: option "-T" for multipath(8) need to be documented in man page
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-17 09:48 UTC by masanari iida
Modified: 2016-11-04 08:18 UTC (History)
6 users (show)

(edit)
documentation fix: not doc text necessary
Clone Of:
(edit)
Last Closed: 2016-11-04 08:18:55 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2536 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2016-11-03 14:18:10 UTC

Description masanari iida 2016-03-17 09:48:18 UTC
Description of problem:
Current man page for multipath(8) doesn't include "-T" option.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-85.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. man multipath

Actual results:
"-T" not documented.

Additional info:

[root@localhost ~]# multipath -h
multipath-tools v0.4.9 (05/33, 2016)

(snip)

  -T tm:val
          check if tm matches the multipathd timestamp. If so val is
          whether or not the device is a path in a multipath device

Comment 2 Ben Marzinski 2016-04-20 18:07:49 UTC
I've added documentation for the -T option to the man page.

Comment 3 Lin Li 2016-04-22 14:32:18 UTC
Reproduced on device-mapper-multipath-0.4.9-85.el7.x86_64 
[root@storageqe-54 ~]# man multipath
"-T" not documented.
[root@storageqe-54 ~]# multipath -h
  -T tm:val
          check if tm matches the multipathd timestamp. If so val is
          whether or not the device is a path in a multipath device



Verified on device-mapper-multipath-0.4.9-89.el7
[root@storageqe-54 ~]# man multipath
      -T tm:valid
              check if tm matches the multipathd configuration timestamp value
              from /run/multipathd/timestamp If so, return success if valid is
              1. Otherwise, return failure. If  the  timestamp  doesn't  match
              continue  with  multipath execution.  This option is designed to
              be used with -c by the udev rules.
[root@storageqe-54 ~]# multipath -h
  -T tm:val
          check if tm matches the multipathd timestamp. If so val is
          whether or not the device is a path in a multipath device

Comment 6 errata-xmlrpc 2016-11-04 08:18:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html


Note You need to log in before you can comment on or make changes to this bug.