Bug 131874 - Kernel panic occurs (oops in __free_pages_ok(), ncpfs in use)
Kernel panic occurs (oops in __free_pages_ok(), ncpfs in use)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Larry Woodman
http://www.sgc.ox.ac.uk/aetherpanic.JPG
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 03:51 EDT by Brian Marsden
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:19:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Marsden 2004-09-06 03:51:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040614 Firefox/0.9

Description of problem:
Kernel panic occured overnight, probably at around 12am. Kernel oops
output (see http://www.sgc.ox.ac.uk/aetherpanic.JPG ) suggests it was
triggered by logwatch.

The machine is fully up2date as of early last week.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.21-15.0.4.EL

How reproducible:
Didn't try

Steps to Reproduce:
Unclear

Actual Results:  Kernel panic

Expected Results:  No kernel panic

Additional info:

ncpfs is compiled as a kernel and was loaded. It was used to mount a
remote Novell filesystem.

The loopback device was in use mounting an ISO image.
Comment 1 Ernie Petrides 2004-09-07 17:36:30 EDT
Hello, Brian.  The ncpfs module is unsupported, and it could
be the source of the problem that later led to the oops in
__free_pages_ok().  Could you please try to reproduce this
problem without ncpfs?

In the meantime, I'll assign this tentatively to someone
familiar with our VM subsystem.
Comment 2 Daniel Hedblom 2005-02-04 02:43:46 EST
I suspect most of the new problems with ncpfs is because of SELinux. I
had to switch it off on my machines running FC3. I got this:

SELinux: initializedc(dev ncpfs, type ncpfs), not configured for labeling

Also got a whole bunch of:

ncpfs: Connection invalid!
Comment 3 RHEL Product and Program Management 2007-10-19 15:19:24 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.