Bug 1318852 - DNF doesn't install groups, reports the group is already installed.
DNF doesn't install groups, reports the group is already installed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
: EasyFix, Triaged
: 1347122 1351879 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-17 22:01 EDT by Eduardo Cruz Reyes
Modified: 2016-10-22 08:56 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-04 14:07:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installed packages, rpm -qa output. (54.76 KB, text/plain)
2016-03-17 22:01 EDT, Eduardo Cruz Reyes
no flags Details

  None (edit)
Description Eduardo Cruz Reyes 2016-03-17 22:01:43 EDT
Created attachment 1137643 [details]
Installed packages, rpm -qa output.

Description of problem:

After early stop groups install with:

# dnf groupinstall "Web Server" "C Development Tools and Libraries" "Cloud Management Tools" "Container Management" "D Development Tools and Libraries" "Development Tools" "RPM Development Tools" "Fedora Eclipse"

DNF reports the groups are already installed:

# dnf groupinstall "Web Server" "C Development Tools and Libraries" "Cloud Management Tools" "Container Management" "D Development Tools and Libraries" "Development Tools" "RPM Development Tools" "Fedora Eclipse"
Last metadata expiration check: 0:40:45 ago on Thu Mar 17 19:09:37 2016.
Environment 'Web Server' is already installed, skipping.
Group 'C Development Tools and Libraries' is already installed, skipping.
Group 'Cloud Management Tools' is already installed, skipping.
Group 'Container Management' is already installed, skipping.
Group 'D Development Tools and Libraries' is already installed, skipping.
Group 'Development Tools' is already installed, skipping.
Group 'RPM Development Tools' is already installed, skipping.

Version-Release number of selected component (if applicable):

dnf-0:1.1.7-2.fc23

How reproducible:

Use DNF to install groups and before all downloads are finished stop the process. After try install the same groups.

Steps to Reproduce:
1. Use DNF to install some groups.
2. Before DNF finish downloads stop the process.
3. Try install the same groups.

Actual results:

Always reproducible.

Expected results:
Everything happens the same, DNF reports "already installed group, skipping..."


Additional info:
See attachments for detailed installed packages.
Comment 1 Couret Charles-Antoine 2016-05-19 08:52:11 EDT
I have the same trouble with DNF 1.1.8.
In addition to this, I could install these groups if I remove this groups, but these groups are not installed in real!

I have a similar trouble to remove these groups after the installation was completed. In fact, I can remove one group in the same time. If I tried to remove two groups at the same time, the groups are tagged as "not installed". But no problem if I remove them separately...
Comment 2 Christian Dersch 2016-05-22 16:38:10 EDT
Also have this issue with dnf-1.1.9-1.fc24, steps to reproduce:

1.) dnf group install development-tools
2.) Answer "no"
3.) dnf group install development-tools
=> dnf now tells me that the group "Development Tools" is already installed although it is not.
Comment 3 Michal Luscon 2016-05-23 02:33:26 EDT
False alarm - this is still an issue in DNF.
Comment 4 Jaroslav Mracek 2016-05-31 08:53:06 EDT
The issues described in the bug report were fixed, but something remains. 
When 'dnf group install <groups>' use as a one group argument nonexistant group it fails, nothing is installed, but all valid groups were marked as installed.
Comment 5 Jaroslav Mracek 2016-06-02 09:46:25 EDT
I made a pull-request: https://github.com/rpm-software-management/dnf/pull/507 .
Hopefully it will solve remaining issues.
Comment 6 Mike FABIAN 2016-06-10 09:36:26 EDT
(In reply to Christian Dersch from comment #2)
> Also have this issue with dnf-1.1.9-1.fc24, steps to reproduce:
> 
> 1.) dnf group install development-tools
> 2.) Answer "no"
> 3.) dnf group install development-tools
> => dnf now tells me that the group "Development Tools" is already installed
> although it is not.

I have the same problem with dnf-1.1.9-2.fc24.noarch
on Fedora-Workstation-netinst-x86_64-24-20160609.n.0.iso
Comment 7 Jaroslav Mracek 2016-06-20 07:58:45 EDT
*** Bug 1347122 has been marked as a duplicate of this bug. ***
Comment 8 Michael Mráka 2016-07-04 07:36:53 EDT
*** Bug 1351879 has been marked as a duplicate of this bug. ***
Comment 9 Richard W.M. Jones 2016-10-13 08:55:40 EDT
I'm seeing this with dnf-1.1.10-1.fc25:

# dnf -y group install buildsys-build
Last metadata expiration check: 0:02:15 ago on Thu Oct  6 03:36:59 2016.
Group 'Buildsystem building group' is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
# rpm -q gcc-c++
package gcc-c++ is not installed

What version was supposed to fix this bug?
Comment 10 Jaroslav Mracek 2016-10-14 06:29:48 EDT
This patch was released only as released candidate of DNF-2.0 into rawhide. DNF-2.0 will be available only for fc26+ according to request for wide-change. DNF-2.0 can be tested on fc24+ from ours copr repository rpmsoftwaremanagement/dnf-nightly .
Comment 11 Jaroslav Mracek 2016-10-22 08:56:18 EDT
According to comment 9, There is new pull-request that should solve your problem:
https://github.com/rpm-software-management/dnf/pull/640

Note You need to log in before you can comment on or make changes to this bug.