Bug 131887 - pcitable references non-existant "isp_mod" module
Summary: pcitable references non-existant "isp_mod" module
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hwdata   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-06 11:51 UTC by Mike Barnes
Modified: 2014-03-17 02:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 21:09:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against pcitable (767 bytes, patch)
2004-09-06 11:53 UTC, Mike Barnes
no flags Details | Diff

Description Mike Barnes 2004-09-06 11:51:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.4 (KHTML, 
like Gecko) Safari/125.9

Description of problem:
The pcitable file in current hwdata still references "isp_mod" as the appropriate module for 
a QLogic ISP1020 SCSI controller. This module was the "Feral" QLogic driver that was 
included in Red Hat shipped kernels based on the 2.4 Linux kernel tree.

The module was never brought up to date to be included in the 2.6 kernel series, and is no 
longer a valid option. The "qlogicisp" module, while probably not the best performing 
option, should be substituted instead - at least it exists.

Version-Release number of selected component (if applicable):
hwdata-0.125-1

How reproducible:
Always

Steps to Reproduce:
1. Boot system containing QLogic 1020 PCI SCSI controller

Additional info:
Simple patch attached, s/isp_mod/qlogicisp/ in "pcitable" will give the exact same 
results.

Comment 1 Mike Barnes 2004-09-06 11:53:05 UTC
Created attachment 103506 [details]
Patch against pcitable

Comment 2 Sammy 2004-09-06 12:56:54 UTC
However, there is another file named upgradelist which seems to 
contain new names vs old names. In there qlogicisp is accociated 
to isp_mod. 

Comment 3 Mike Barnes 2004-09-06 13:08:01 UTC
Still managed to trip up my system - can't recall the exact circumstances, but it was in the 
course of working with a custom distro and Anaconda. Had to patch hwdata before it'd all 
work out.

I figured the upgrade list to be exactly that - module translations for upgrades. Didn't 
quite seem to get picked up in a "new install" context. I can back out my patch and try 
narrow down the point it happens at, if that's not the expected behavior of the system.

But is there any point leaving it in there? Looks like the Feral driver is dead. I'd love to see 
it come back, I must admit ...

Comment 4 Bill Nottingham 2004-09-06 21:09:39 UTC
Will be in in 0.131-1.


Note You need to log in before you can comment on or make changes to this bug.