Bug 1319003 - ipa-winsync-migrate: Traceback should be fixed with proper console output
Summary: ipa-winsync-migrate: Traceback should be fixed with proper console output
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-18 11:58 UTC by Sudhir Menon
Modified: 2016-11-04 05:52 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:52:24 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-03-18 11:58:13 UTC
Description of problem: ipa-winsync-migrate: Traceback should be fixed with proper console output

Version-Release number of selected component (if applicable):
ipa-server-trust-ad-4.2.0-15.el7_2.10.x86_64
ipa-server-4.2.0-15.el7_2.10.x86_64

How reproducible:Always.

Steps to Reproduce:
1. Ensure ipa related rpms are installed.
2. Ensure ipa-server-install is not run.
3. Now try to run command 'ipa-replica-prepare' and check console output.
4. Now try to run command 'ipa-winsync-migrate' and check console output.

Actual results:

Step3:
[root@host2 ipa-idoverride]# ipa-replica-prepare 
IPA is not configured on this system.

Step4:
[root@host2 ~]# ipa-winsync-migrate 
ipa: WARNING: session memcached servers not running
Traceback (most recent call last):
  File "/usr/sbin/ipa-winsync-migrate", line 23, in <module>
    WinsyncMigrate.run_cli()
  File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 124, in run_cli
    sys.exit(cls.main(sys.argv))
  File "/usr/lib/python2.7/site-packages/ipaserver/install/ipa_winsync_migrate.py", line 346, in main
    api.Backend.ldap2.connect(ccache)
  File "/usr/lib/python2.7/site-packages/ipalib/backend.py", line 63, in connect
    conn = self.create_connection(*args, **kw)
  File "/usr/lib/python2.7/site-packages/ipaserver/plugins/ldap2.py", line 149, in create_connection
    client_controls=clientctrls)
  File "/usr/lib/python2.7/site-packages/ipapython/ipaldap.py", line 1070, in gssapi_bind
    '', auth_tokens, server_controls, client_controls)
  File "/usr/lib64/python2.7/contextlib.py", line 35, in __exit__
    self.gen.throw(type, value, traceback)
  File "/usr/lib/python2.7/site-packages/ipapython/ipaldap.py", line 975, in error_handler
    error=info)
ipalib.errors.NetworkError: cannot connect to 'ldap://localhost:389': 

Expected results:
When IPA server is not installed/configured and when commands are run on the console, they should display message like "IPA is not configured" instead of displaying a traceback on the console.

All other command line options display proper message on the console.

Additional info:

Comment 2 Petr Vobornik 2016-03-24 19:35:18 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5767

Comment 3 Petr Vobornik 2016-08-03 13:09:28 UTC
Sudhir, could you retest with ipa 4.4? According to https://fedorahosted.org/freeipa/ticket/5767#comment:3 it seems, that it might be already fixed.

Comment 4 Sudhir Menon 2016-08-03 13:21:17 UTC
Petr,
Yes, the fix is already in the below packages.

Verified using the below rpms.
ipa-server-4.4.0-4.el7.x86_64

[root@client ~]# ipa-replica-prepare 
IPA is not configured on this system.
The ipa-replica-prepare command failed.
[root@client ~]# ipa-winsync-migrate 
IPA is not configured on this system.

Comment 5 Petr Vobornik 2016-08-03 15:42:26 UTC
Setting correct state according to comment 4.

Comment 7 Sudhir Menon 2016-08-09 18:39:41 UTC
Verified using the below rpms.
ipa-server-4.4.0-4.el7.x86_64

[root@client ~]# ipa-replica-prepare 
IPA is not configured on this system.
The ipa-replica-prepare command failed.
[root@client ~]# ipa-winsync-migrate 
IPA is not configured on this system.

Comment 9 errata-xmlrpc 2016-11-04 05:52:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.