Bug 131901 - HelixPlayer doesn't process commandline arguments
HelixPlayer doesn't process commandline arguments
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: HelixPlayer (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks: 131589
  Show dependency treegraph
 
Reported: 2004-09-06 11:09 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.0.1.gold-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 16:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-09-06 11:09:26 EDT
Description of problem:
I think HelixPlayer probably needs to run update-mime-database or
update-desktop-database (or both) in %post and %postun, like gimp, eog
and file-roller do.

Version-Release number of selected component (if applicable):
1.0.gold-3
Comment 1 Colin Walters 2004-09-07 15:52:20 EDT
update-desktop-database isn't useful until HelixPlayer actually uses
the new MIME system (which is the real bug here :/).

I have the call to u-d-d in CVS, but it's pending on upstream response
to the MIME setup.
Comment 2 Colin Walters 2004-09-21 17:56:58 EDT
This bug is upstream here:
https://bugs.helixcommunity.org/show_bug.cgi?id=3101

Keeping it open here so it's visible on my list of things to fix.
Comment 3 Jonathan Blandford 2004-09-30 15:47:53 EDT
Can we just patch their .desktop file as a short term fix?
Comment 4 Colin Walters 2004-09-30 17:32:01 EDT
Hmm...actually this seems to be done now.  I guess upstream has had
the MimeType and I missed it somehow?

Anyways, it works for me, closing.
Comment 5 Colin Walters 2004-09-30 17:34:28 EDT
Actually I forgot, the main bug here is that the player seems to not
process commandline arguments correctly.
Comment 6 Colin Walters 2004-10-07 16:32:43 EDT
This was a bug in the spec file.

Note You need to log in before you can comment on or make changes to this bug.