Bug 131905 - Magicdev turns into zombie mode
Magicdev turns into zombie mode
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: magicdev (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 11:55 EDT by Drup4
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-09 17:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Drup4 2004-09-06 11:55:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Magicdev dies during xorg runtime and cannot be killed with kill
either by name nor process number. When exiting Xorg at this point the
logout is stuck until xorg detects hanging daemons and terminates
itself. However magicdev stays in memory as a zombie process, and
cannot be killed (Even not when I kill Xorg with ctrl+alt+backspace).
I need to shutdown and reboot the sytem to kill the magicdev process
which at that point keeps all the mounts locked so after a couple of
errors it reboots without unmounting anything (crossed fingers at this
point :P). 
I'm not sure where this comes from but I believe that this problem
starts after running the TvTime Television viewer applet, but I'm
totaly fishing in the dark here, the only thing I know is when I start
the above mentioned app the problems usualy start.. :)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Activate Xorg
2.load TvTime televion vieuwer into memory
3. shutdown tv applet and then try to logout xorg

    

Additional info:
Comment 1 Drup4 2004-09-06 17:30:23 EDT
Temporary fix seems to be disabling all autorun features which pretty
much corners magicdev. Still trying to get a grasp on the exact
trigger thingy...
Comment 2 John (J5) Palmieri 2004-09-09 17:08:58 EDT
Marking wontfix. Magicdev is replaced in FC3 by gnome-volume-manager.
 Suggest keeping autorun disabled and upgarde to FC3 when available.

Note You need to log in before you can comment on or make changes to this bug.