Bug 131919 - U3 turns httpd off
U3 turns httpd off
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 15:16 EDT by Zenon Panoussis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:19:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2004-09-06 15:16:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Applying the U3 updates turns httpd off: 
# chkconfig --list httpd
httpd           0:off   1:off   2:off   3:off   4:off   5:off   6:off

This was a working system with httpd set to on at RL 345, suddenly
going off through the update. 

Version-Release number of selected component (if applicable):
2.0.46-38.ent

How reproducible:
Not going to try.
Comment 1 Joe Orton 2004-09-06 16:03:26 EDT
Thanks for the report.  

We can't seem to reproduce the issue here.  You had used "chkconfig
httpd on" to enable the service, as normal?  This is on i686, RHEL3
AS?  Was the previously installed httpd package the latest erratum
version?

From the U2 httpd packages, the following sequence works as expected:

# chkconfig httpd on
# chkconfig --list httpd
httpd           0:off   1:off   2:on    3:on    4:on    5:on    6:off
# up2date -u httpd
...
# chkconfig --list httpd
httpd           0:off   1:off   2:on    3:on    4:on    5:on    6:off
Comment 2 Zenon Panoussis 2004-09-06 16:15:17 EDT
> You had used "chkconfig httpd on" to enable the service, as normal?

Yes, as I said, the service was enabled at RL 345 and was running
fine. The preceding httpd was 2.0.46-32.ent.3.i386.rpm . After the
update (and having touched nothing else related), it was suddenly off
at all runlevels. I only found out because I rebooted and the
webserver was gone. 

chkconfig was also updated in this run. Theoretically, this could be
its fault too. It's rather unlikely however, and no other services
changed state either. 
Comment 3 Zenon Panoussis 2004-09-06 16:20:17 EDT
Oops, I missed a couple of your questions. Yes, i686, RHEL3 AS U2
being updated to U3. I updated httpd while it was running, then did
"service httpd restart" and nothing else. 
Comment 4 Joe Orton 2004-09-07 05:41:34 EDT
OK, the behaviour you describe is equivalent to running "chkconfig
--del httpd" and then "chkconfig --add httpd".  "chkconfig --add
httpd" is always run after upgrading the package.

After you updated to U3, can you confirm that the httpd daemon was
still running, before the reboot?  The error could occur if for some
reason the httpd package's %preun script was invoked incorrectly
during the update, but this would also have stopped the service:

%preun
if [ $1 = 0 ]; then
        /sbin/service httpd stop > /dev/null 2>&1
        /sbin/chkconfig --del httpd
fi

If that is not the case, it's not clear how this has happened.
Comment 5 Joe Orton 2004-09-07 05:44:52 EDT
Could you include the output of:

# rpm -V httpd chkconfig

just to double-check the packages are installed correctly.
Comment 6 Zenon Panoussis 2004-09-07 06:25:27 EDT
I updated in serveral steps. Apache in one run, then a few hours later
the kernel, which caused me to reboot. Yet later I saw that apache was
down. I can see in the logs when apache stopped and when I rebooted,
but not when I applied the update, and for my life I can't remember
either. Thus, all I know is that apache was already down when I
rebooted. Also, I know that it was running when I applied the update,
because I restarted it and got [OK] on both stop and start. There is
no telling when its init got unconfigured though.

# rpm -V httpd chkconfig
S.5....T c /etc/httpd/conf/httpd.conf

Comment 7 RHEL Product and Program Management 2007-10-19 15:19:21 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.