Bug 131922 - Samba logs filled with utf8 error messages
Samba logs filled with utf8 error messages
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 16:29 EDT by Johan Dahl
Modified: 2014-08-31 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-16 18:21:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Dahl 2004-09-06 16:29:19 EDT
Description of problem:

Samba logfiles is filled with utf8 errors. They are produced on
loglevel 0 (zero) so they can't be removed.

Version-Release number of selected component (if applicable):

samba-3.0.4-6.3E

How reproducible:

Happens all the time as files with umlaut charaters. They are valid
chars. The show up correctly in console, in nautilius window and on
client PC but samba still complains.

Steps to Reproduce:
1. Start samba server
2. Connect a computer with a swedish version of Windows XP
3. Watch log fill with utf8 error messages
  
Actual results:

Using loglevel 1. Opening a folder called "Räksmörgås"
(Shrimp-sandwich) on a client PC produces this item about 20 times in
the log.

[2004/09/06 22:27:44, 0] lib/iconv.c:utf8_pull(514)
  short utf8 char


Expected results:

Nothing in the log.

Additional info:

These settings are used in smb.conf which has some sigificans towards
this. 

	unix charset = UTF8
	display charset = UTF8
	dos charset = CP850
Comment 1 Johan Dahl 2004-09-20 13:30:53 EDT
I have tested samba-3.0.7-2.FC2 on Fedora Core 2 and it doens't
generate these messages.
Comment 2 Johan Dahl 2004-09-23 16:39:20 EDT
I now uses samba samba-3.0.7-1.3E on RHEL 3 and this message is still
generated. In a swedish roaming profile there is several folders with
umlaut-characters so a normal windows login produces hundreds of items
in the log.

[2004/09/23 22:30:41, 0] lib/iconv.c:utf8_pull(518)
  short utf8 char

Comment 3 Johan Dahl 2004-12-16 18:21:29 EST
I now uses samba-3.0.9-1.3E.1 and the issue is solved. I haven't
gotten any utf-8 errors so far. God work!!!

Note You need to log in before you can comment on or make changes to this bug.