Bug 131936 - $IMDIR in m4 macro in im-sdk has hardcoded libdir
$IMDIR in m4 macro in im-sdk has hardcoded libdir
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-09-07 00:11 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 01:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2004-09-07 00:11:19 EDT
Description of problem:
The IMDIR in m4 macro in im-sdk has hardcoded libdir - i.e. /usr/lib
in im-sdk/trunk/acfiles/im_common.m4. Hence when buliding into 64bit
arch, spec file has to do a search and replace hack to replace
s#/usr/lib/im#/usr/lib64/im#gi

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. build one of the LE without the search and replace hack in x86_64
2. look into /usr/lib64/im after make install
  
Actual results:
nothing

Expected results:
libraries should install into /usr/lib64

Additional info:
Low priority but it is great to fix it so that im-sdk.spec and other
spec that rely on those macros won't have to do such hacks.
Comment 1 Yu Shao 2004-09-07 00:36:06 EDT
the spec file hack must have been there from very early stage, anyway
needs to be fixed. 

but if LE is using configure --prefix=%{im_dir}, and in makefile use
things like "libdir = $(prefix)/locale/zh_CN/chinput" LE shouldn't be
affected.

Comment 2 Akira TAGOH 2005-03-31 01:45:59 EST
FYI, I've fixed im_common.m4 properly in svn yesterday. I mean --with-imdir is
available now. it would be good rather than using IMDIR="${libdir}/iiim",
because there is the case it doesn't work so that libdir is
${exec_prefix}/lib/iiim unless --libdir isn't specified.
For the multilib support, --with-imdir should works perfectly. it will be
available soon for us.
Comment 3 Akira TAGOH 2005-04-04 10:07:30 EDT
should be fixed in 12.1.1-11.svn2435.
Comment 4 Leon Ho 2005-04-07 01:53:08 EDT
Yup. Thank you Tagoh-san.

Note You need to log in before you can comment on or make changes to this bug.