Bug 1319442 - Allow hugetlbfs for apache
Summary: Allow hugetlbfs for apache
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.2
Hardware: All
OS: Linux
high
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Stefan Dordevic
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 1365802 1393465
TreeView+ depends on / blocked
 
Reported: 2016-03-20 06:21 UTC by Frank Büttner
Modified: 2016-11-09 15:34 UTC (History)
8 users (show)

(edit)
Clone Of:
: 1330981 1392406 1393465 (view as bug list)
(edit)
Last Closed: 2016-11-04 02:45:22 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2283 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2016-11-03 13:36:25 UTC

Description Frank Büttner 2016-03-20 06:21:11 UTC
Description of problem:
When using PHP7 under RHEL gen7, then an SELinux 

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.13.1-60.el7_2.3.noarch

How reproducible:
Run php7 in fpm mode.


Actual results:
type=SYSCALL msg=audit(1458404646.353:88331): arch=c000003e syscall=9 success=no exit=-13 a0=0 a1=8000000 a2=3 a3=40021 items=0 ppid=1 pid=2611 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="php-fpm" exe="/opt/remi/php70/root/usr/sbin/php-fpm" subj=system_u:system_r:httpd_t:s0 key=(null)
type=AVC msg=audit(1458404871.831:88338): avc:  denied  { write } for  pid=2685 comm="php-fpm" path=2F616E6F6E5F6875676570616765202864656C6574656429 dev="hugetlbfs" ino=3811400 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:hugetlbfs_t:s0 tclass=file

Expected results:
Working php7

Additional info:
Needed policy:
module phpfpm 1.0;

require {
        type httpd_t;
        type hugetlbfs_t;
        class file write;
}

#============= httpd_t ==============
allow httpd_t hugetlbfs_t:file write;

Comment 2 Frank Büttner 2016-03-20 06:39:48 UTC
It comes from the opcache of PHP7.
The default config of it is:
; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
; This should improve performance, but requires appropriate OS configuration.
opcache.huge_code_pages=1

Comment 8 errata-xmlrpc 2016-11-04 02:45:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html


Note You need to log in before you can comment on or make changes to this bug.