Bug 1319506 - Can't close initial-setup's help window
Summary: Can't close initial-setup's help window
Status: CLOSED DUPLICATE of bug 1160891
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
Depends On:
Blocks: F24AlphaFreezeException F24FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2016-03-20 18:43 UTC by Giulio 'juliuxpigface'
Modified: 2016-03-24 12:24 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-03-24 12:24:45 UTC


Attachments (Terms of Use)
initial-setup's help screen (324.04 KB, image/png)
2016-03-20 18:43 UTC, Giulio 'juliuxpigface'
no flags Details

Description Giulio 'juliuxpigface' 2016-03-20 18:43:56 UTC
Created attachment 1138357 [details]
initial-setup's help screen

Description of problem:
On Fedora 24 Alpha 1.6, it's impossible to close (or move away) the window containing the help screen.

Version-Release number of selected component (if applicable):
initial-setup-0.3.39-1.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Install a Fedora 24 Spin (not Gnome), without creating an user account.
2.When rebooting, wait until initial-setup starts.
3.Click the "help" button.

Actual results:
1. It's impossible to change focus to initial-setup's main window. It's then impossible to input the required datas.
2. The help facility runs, but can't be closed.


Expected results:
1/2. Users should be able to switch to the main window nor close the help screen.

Additional info:
1 - This might be related to https://bugzilla.redhat.com/show_bug.cgi?id=1160891
2 - Screenshot attached

Comment 1 Giulio 'juliuxpigface' 2016-03-20 18:58:10 UTC
Similarly to https://bugzilla.redhat.com/show_bug.cgi?id=1160891, I'm proposing this as FE for Alpha and as Blocker for Final. I've hit this with Fedora KDE and it makes the utility quite unusable.

Criterion: 2.4.1 Expected installed system boot behavior (Fedora 24 Alpha).

"On the first boot after installation, a utility for creating user accounts and other configuration may (may, not must) run prior to a log in screen appearing."

Comment 2 Kamil Páral 2016-03-21 17:04:43 UTC
Discussed at today's blocker review meeting [1]. Voted as AcceptedFreezeException (Alpha) - this is obviously a serious issue that can't be fixed with an update. If it can be fixed without touching anaconda, we will likely take the fix. However, if the fix requires change to anaconda (the bug is the same as #1319590) we won't

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-21

Comment 3 Martin Kolman 2016-03-24 12:24:45 UTC
Turns out this had the same cause as bug 1160891 - window manager not running.

*** This bug has been marked as a duplicate of bug 1160891 ***


Note You need to log in before you can comment on or make changes to this bug.