Bug 1319581 - Marker: Lot of dict_get errors in brick log!!
Summary: Marker: Lot of dict_get errors in brick log!!
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: marker
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1332074
TreeView+ depends on / blocked
 
Reported: 2016-03-21 06:11 UTC by Kotresh HR
Modified: 2016-06-16 14:01 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1332074 (view as bug list)
Environment:
Last Closed: 2016-06-16 14:01:05 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2016-03-21 06:11:18 UTC
Description of problem:
There are dict_get errors in the brick log.

Error in log:
[2016-03-21 05:25:03.525473] I [dict.c:463ict_get]
(-->/usr/local/lib/libglusterfs.so.0(default_getxattr_cbk+0xe5)
[0x7f019da0a1f5]
-->/usr/local/lib/glusterfs/3.8dev/xlator/features/marker.so(+0xd27e) [0x7f0191afe27e] -->/usr/local/lib/libglusterfs.so.0(dict_get+0x7e)
[0x7f019d98ac8e] ) 0-dict: !this || key=() [Invalid argument]

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
When geo-rep.indexing is not enabled and getxattr is done on any xattr.

Actual results:
Dict get error logs are seen

Expected results:
dict_get errors should not be seen.

Additional info:

Comment 1 Kotresh HR 2016-03-21 06:52:31 UTC
The issue is reproducible when getxattr is done on any file in gluster mount when geo-rep.indexing is not enabled and quota is enabled.

Comment 2 Vijay Bellur 2016-03-21 06:53:48 UTC
REVIEW: http://review.gluster.org/13793 (features/marker: Fix dict_get errors when key is NULL) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 3 Mike McCune 2016-03-28 22:53:35 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 4 Vijay Bellur 2016-03-29 06:50:27 UTC
REVIEW: http://review.gluster.org/13793 (features/marker: Fix dict_get errors when key is NULL) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 5 Vijay Bellur 2016-04-21 11:37:45 UTC
COMMIT: http://review.gluster.org/13793 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit fb55cf6aea208b8f493adc011b3b0a0d734cc8a1
Author: Kotresh HR <khiremat@redhat.com>
Date:   Mon Mar 21 12:01:47 2016 +0530

    features/marker: Fix dict_get errors when key is NULL
    
    Change-Id: I25e497459441334c13af77b3fec83c42a7a92ac4
    BUG: 1319581
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/13793
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    Reviewed-by: Vijaikumar Mallikarjuna <vmallika@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>

Comment 6 Niels de Vos 2016-06-16 14:01:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.