Bug 1319590 - Fedora 24 Alpha 1.6 (Server - DVD): Can't close help window, once opened
Summary: Fedora 24 Alpha 1.6 (Server - DVD): Can't close help window, once opened
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker RejectedFreezeException
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-21 07:17 UTC by Giulio 'juliuxpigface'
Modified: 2016-04-06 14:06 UTC (History)
8 users (show)

Fixed In Version: anaconda-24.13.2-1 anaconda-24.13.3-1.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-06 14:06:30 UTC


Attachments (Terms of Use)
F24-Server-Dvd's help (333.03 KB, image/png)
2016-03-21 07:17 UTC, Giulio 'juliuxpigface'
no flags Details

Description Giulio 'juliuxpigface' 2016-03-21 07:17:12 UTC
Created attachment 1138439 [details]
F24-Server-Dvd's help

Description of problem:
On Fedora 24 Server (dvd), I can't close the 'help' window once it's opened and enlarged during the installation.

Version-Release number of selected component (if applicable):
anaconda-24.13-1.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora-Server-dvd-x86_64-24_Alpha-1.6.iso.
2. On the language spoke, open the help window.
3. Double click on it.

Actual results:
The help window is opened, but I didn't find an easily way to close it. Moreover, the dialog is not "sizable".

Expected results:
Users should be able to close the help window.

Additional info:
1. I'm attaching a screenshot.
2. I'm testing with qemu-kvm.

Comment 1 Fedora Blocker Bugs Application 2016-03-21 07:22:40 UTC
Proposed as a Blocker and Freeze Exception for 24-alpha by Fedora user juliuxpigface using the blocker tracking app because:

 This is a potential violation of the "2.3.4 Installation interfaces" Alpha Release Criteria.

"When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces. "

However, I'd be more into FE for Alpha, since not every user will notice the issue.


Link: https://fedoraproject.org/wiki/Fedora_24_Alpha_Release_Criteria#Installation_interfaces

Comment 2 Stephen Gallagher 2016-03-21 11:11:42 UTC
I can confirm this bug and if we have a fix for it, I'd take it as an FE, but I don't think it fits the blocker criterion. The installer *is* able to complete the installation.

Also, there is a workaround: on bare-metal or on VMs that are in fullscreen mode, the window accepts ctrl-w to close it. (On virt-manager, this command normally tries to close the spice window, but full-screening allows the command to reach the system).

-1 Blocker, +1 FE

Comment 3 David Shea 2016-03-21 14:06:36 UTC
https://github.com/rhinstaller/anaconda/pull/559

And this is absolutely not a blocker. In addition to the workaround in comment 2, you can just click somewhere off the window and keep going from there.

Comment 4 Stephen Gallagher 2016-03-21 14:18:58 UTC
(In reply to David Shea from comment #3)
> https://github.com/rhinstaller/anaconda/pull/559
> 
> And this is absolutely not a blocker. In addition to the workaround in
> comment 2, you can just click somewhere off the window and keep going from
> there.

I will note that if, while trying to figure out ways to clear it, you do as I do and double-click on the title-bar, it *does* end up fullscreening and makes clicking off the window impossible.

That said, I'm still -1 blocker. I also am backing out my +1 FE at the moment, because I remembered that pulling this in would also pull in the C.UTF-8 problem and this is not important enough to force us to deal with that as well.

Comment 5 Kamil Páral 2016-03-21 16:44:59 UTC
Discussed at today's blocker review meeting [1]. Voted as RejectedBlocker (Alpha), RejectedFreezeException (Alpha) - this is not severe enough to constitute the installer failing to complete, for Alpha (it's a conditional violation only in the case of opening Help, and it's workaroundable). we might usually accept it as FE, but as it's late in the cycle and there is known risk of breakage elsewhere in anaconda with new builds, we are rejecting it as FE as well

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2016-03-21

Comment 6 Fedora Update System 2016-03-31 19:43:14 UTC
anaconda-24.13.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ed73149773

Comment 7 Fedora Update System 2016-04-04 21:25:34 UTC
anaconda-24.13.3-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7

Comment 8 Fedora Update System 2016-04-05 19:22:09 UTC
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd26edfec7

Comment 9 Fedora Update System 2016-04-06 14:06:11 UTC
anaconda-24.13.3-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.