Bug 1319630 - Networking snippet creating config files with wrong device name for alias and vlan interfaces
Summary: Networking snippet creating config files with wrong device name for alias and...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-21 08:46 UTC by Sachin Ghai
Modified: 2019-09-26 17:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:07:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
virtual interface configuration on rhel6 host (90.44 KB, image/png)
2016-04-11 11:07 UTC, Sachin Ghai
no flags Details
virtual interface configuration on rhel7 host (60.91 KB, image/png)
2016-04-11 11:09 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 13000 None None None 2016-04-22 15:02:47 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2016-03-21 08:46:45 UTC
Description of problem:
I was trying to configure alias and vlan interfaces on rhel7 host using static subnet. Host was provisioned successfully, but none of the interfaces configured.

I checked the interface configs are found that device names were incorrect.

Alias interface config file named ike:
 /etc/sysconfig/network-scripts/ifcfg-_0

[root@sghai ~][root@sghai ~]# cat /etc/sysconfig/network-scripts/ifcfg-_0  | grep DEVICE
DEVICE=:0


vlan inteface config file named as:
/etc/sysconfig/network-scripts/ifcfg-.1

[root@sghai ~]# cat /etc/sysconfig/network-scripts/ifcfg-.1  | grep DEVICE
DEVICE=.1



Version-Release number of selected component (if applicable):
sat6.2 beta snap4

How reproducible:
always

Steps to Reproduce:
1. configure alias and vlan interfaces on rhel7
2.
3.

Actual results:
incorrect device names in alias and interface config files 


Expected results:
Device names sould be correct

Additional info:

Comment 7 Bryan Kearney 2016-03-25 18:10:53 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/13000 has been closed
-------------
Marek Hulán
Applied in changeset commit:community-templates|673a05b33c3efcb2db4bf29306a7086a22f5e43f.

Comment 8 Sachin Ghai 2016-04-07 10:07:38 UTC
Verified with sat6.2 beta snap6.2

when we provision a host by adding a alias interface, host provisioned successfully but with incorrect alias interface name:


[root@alias network-scripts]# cat ifcfg-_0
BOOTPROTO="none"
IPADDR="192.168.100.120"
NETMASK="255.255.255.248"
DEVICE=:0
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
TYPE=Alias


however, if I rebuild the same host then interface comes up correctly:

[root@alias network-scripts]# cat ifcfg-eth0_0 
BOOTPROTO="none"
IPADDR="192.168.100.120"
NETMASK="255.255.255.248"
DEVICE=eth0:0
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
TYPE=Alias
[root@alias network-scripts]# ifconfig
-bash: ifconfig: command not found
[root@alias network-scripts]# ifconfig -a
-bash: ifconfig: command not found
[root@alias network-scripts]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:aa:2b:04 brd ff:ff:ff:ff:ff:ff
    inet 192.168.100.5/24 brd 192.168.100.255 scope global dynamic eth0
       valid_lft 43094sec preferred_lft 43094sec
    inet 192.168.100.120/29 brd 192.168.100.127 scope global eth0:0
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:feaa:2b04/64 scope link 
       valid_lft forever preferred_lft forever

Comment 9 Sachin Ghai 2016-04-07 10:08:14 UTC
same issue with rhel6 host.

[root@aliasrhel6 network-scripts]# ll | grep ifcfg-
-rw-r--r--. 1 root root   125 Apr  7 10:00 ifcfg-_0
-rw-r--r--. 1 root root    94 Apr  7 10:00 ifcfg-eth0
-rw-r--r--. 1 root root   254 Apr  9  2015 ifcfg-lo
[root@aliasrhel6 network-scripts]# cat ifcfg-_0 
BOOTPROTO="none"
IPADDR="192.168.100.121"
NETMASK="255.255.255.248"
DEVICE=:0
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
TYPE=Alias
[root@aliasrhel6 network-scripts]#

Comment 10 Sachin Ghai 2016-04-11 07:32:01 UTC
Okay, Marek and I worked together to find the root cause of issue. Thanks Marek for your help.

Finally, we got to know that user needs to specify the identifier for first interface.

when we provision a virtual host from satellite6, webUI doesn't set the identifier for first interface. However, when we create alias of first interface, we need to specified the identifier under "attached_to" otherwise, alias interface won't be configured and it fails silently.

However, UI should raise a validation error for alias interface, if user forget to set the identifier for first interface.  I'll file a new bz.

Comment 11 Sachin Ghai 2016-04-11 10:47:39 UTC
By mistake, closed this bz. Moving this back to ON_QA so that I can move it to verified state it.

Comment 12 Sachin Ghai 2016-04-11 11:05:42 UTC
As per comment10, original issue has been fixed. Moving this to verified. I can create virtual interfaces on rhel6 and rhel7 host.

Please see the screenshots for verification.

Comment 13 Sachin Ghai 2016-04-11 11:07:36 UTC
Created attachment 1145922 [details]
virtual interface configuration on rhel6 host

Comment 14 Sachin Ghai 2016-04-11 11:09:45 UTC
Created attachment 1145923 [details]
virtual interface configuration on rhel7 host

Comment 15 Sachin Ghai 2016-04-11 11:10:34 UTC
For validation error issue mentioned in comment10, filed this bz:

https://bugzilla.redhat.com/show_bug.cgi?id=1325777

Comment 17 errata-xmlrpc 2016-07-27 09:07:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.